Suse 9.0 and pb

Linux specific forum
User avatar
Brujah
Enthusiast
Enthusiast
Posts: 237
Joined: Mon Nov 03, 2003 7:45 pm
Location: Germany
Contact:

Suse 9.0 and pb

Post by Brujah »

Hy folks,

my purebasic worked fine using Debian, but now I had to install Suse 9.0 and I can't get it working here.

I get the following error message when I try to compile my program:

/usr/lib/gcc-lib/i586-suse-linux/3.3.1/../../../i586-suse-linux/bin/ld: cannot find -lXi
collect2: ld returned 1 exit status.

I installed sdl-devel and gtk-devel.

What else could be wrong here ?

Markus
Fred
Administrator
Administrator
Posts: 14650
Joined: Fri May 17, 2002 4:39 pm
Location: France
Contact:

Post by Fred »

strange, I don't know what is 'Xi' about.. could you check if you do gtk-config and sdl-config to see what it output ?
User avatar
Brujah
Enthusiast
Enthusiast
Posts: 237
Joined: Mon Nov 03, 2003 7:45 pm
Location: Germany
Contact:

Post by Brujah »

Okay, I tried the following:

gtk-config --version
1.2.10

gtk-config --libs
-lXi -lX11 -lm (and a few more)

I don't know what that means...
User avatar
Brujah
Enthusiast
Enthusiast
Posts: 237
Joined: Mon Nov 03, 2003 7:45 pm
Location: Germany
Contact:

Post by Brujah »

sdl-config --version
1.2.5

sdl-config --lib
-lm -ldl -lX11 -laa (and some more)
User avatar
Brujah
Enthusiast
Enthusiast
Posts: 237
Joined: Mon Nov 03, 2003 7:45 pm
Location: Germany
Contact:

Solved!

Post by Brujah »

After I installed kdevelop it was working!

I don't know. Maybe some libs were missing.
Post Reply