It is currently Sun Feb 28, 2021 5:13 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Which Gadgets/Functions require libwebkitgtk-3.0 (linker)?
PostPosted: Mon Jun 29, 2020 1:35 pm 
Offline
Addict
Addict
User avatar

Joined: Mon Jun 06, 2005 2:35 pm
Posts: 1259
Location: germany
Hi,

I want to use

Code:
ImportC "/usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so"

but in my bigger project, the linker always seem to import libwebkitgtk-3.0.so.0 as it seem to be required for some other thing. I checked all my code and there is no use of WebGadget() in any include. So I think that some PB function or some other gadget may force the linker to include libwebkitgtk-3.0.

Does anyone know what PB function or Gadget is requiring libwebkitgtk-3.0?

UPDATE:
I just found by trial and error that using any XMLDialog function (DialogWindow(), CreateDialog() etc) forces the Purebasic compiler to link libwebkitgtk-3.0. I do not understand as the WebKit browser API does not really offer any helpful functionality (except for its own usage).

Is there a way to use XMLDialog without Purebasic linking against libwebkitgtk-3.0? This is currently completely messing up everything.

I'm really pissed off now. The libwebkitgtk-3.0, used by PureBasic, is not available on most modern Linux Desktops (eg Ubuntu from 19.04 until 20). This is known since January 2018 and did not change until today (mid 2020). And working around this limitation using libwebkit2gtk-4.0 fails because the PureBasic XMLDialog links libwebkitgtk-3.0 for whatever reason. So I can not change my project to use libwebkit2gtk-4.0 together with XMLDialogs (what I do in all projects). And my programs do not run on any modern Linux Desktop...

Is there some basic HTML+CSS rendering engine available for usage in PB without the overhead of 50 megabytes?


Last edited by Kukulkan on Tue Jun 30, 2020 3:10 pm, edited 1 time in total.

Top
 Profile  
Reply with quote  
 Post subject: Re: Which Gadgets/Functions require libwebkitgtk-3.0 (linker
PostPosted: Tue Jun 30, 2020 11:06 am 
Offline
Addict
Addict
User avatar

Joined: Mon Jun 06, 2005 2:35 pm
Posts: 1259
Location: germany
I do not really need a solution anymore. There is no way to get rid of libwebkitgtk-3.0 if XMLDialog or WebGadget is used. The only solution is QT subsystem, but I can not switch that big project easily.

So it is impossible to run PB executables with XMLDialog or Webgadget on Ubuntu 19.04 and newer. Also other distros are affected (some Linux Mint I think). It is known that libwebkitgtk-3.0 will go away since January 2018 and got never fixed.

Sadly, I believe we will have to port our software using another programming language soon (I think it will be golang with sciter). We already lost a customer because of this...


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye