Aktuelle Zeit: 19.08.2019 22:36

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 8 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Icon verschwunden
BeitragVerfasst: 13.07.2019 18:53 
Offline

Registriert: 21.01.2008 19:11
Hallo!

Ich stehe gerade (mal wieder) auf dem Schlauch. :?

Folgende Situation:
Ich hatte ein Programm mit PB erstellt. Dieses nutzt ein Programm-Icon,
welches in den Compiler Optionen eingetragen ist.
Das Icon erscheint in der Titleleiste des Programmfensters und in der
Taskbar. Soweit so gut.
Ich hatte das Programm "angeheftet", so daß das Icon auch nach dem
Schließen des Programms weiterhin in der Taskbar sichtbar war und das
Programm sofort damit wieder gestartet werden konnte. Soweit so gut.
Das lief so über Monate wunderbar.
Jetzt hatte ich versehentlich das Programm von der Taskleiste gelöst.
Das Icon verschwindet dann natürlich von der Taskbar. Soweit auch
noch in Ordnung. Also das Programm gestartet und wieder "angeheftet".
Jetzt passierts: Das Programmicon wechselt jetzt auf das nichtssagende
Standard-Windows-Icon. Wird das Programm wieder von der Taskleiste
gelöst, ist das Programmicon wieder da. :shock:
Kompiliere ich das Programm in einen anderen Ordner und starte es von
dort, funktioniert das "Anheften". Das Icon bleibt.
Verschieb ich jetzt diese Datei an den eigentlichen Platz des Programms,
verschwindet das Programmicon beim "Anheften" wieder. :o
Lasse ich das Programm mit F5 aus PB heraus starten, bleibt das Icon
ebenfalls erhalten.
Verschiebe ich das Programm in den übergeordneten Ordner und starte
es von dort, funkioniert das "Anheften" auch. Das Icon bleibt.

Also kurz gesagt, wird das Programm aus dem ursprünglichen Ordner
heraus gestartet (ob alt oder neu kompiliert), verschwindet das Icon
beim "Anheften". Von allen anderen Orten aus bleibt das Icon erhalten.
:? :? :?

Hat da jemand einen Tip, was da plötzlich schief läuft oder was ich
falsch mache?

_________________
Bild


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Icon verschwunden
BeitragVerfasst: 13.07.2019 19:04 
Offline
Benutzeravatar

Registriert: 08.09.2004 00:57
Wohnort: Berlin
Hast Du in den Compiler-Optionen auch den absoluten Pfad zum Icon eingetragen oder nur einen relativen?

_________________
PureBasic 5.70 | SpiderBasic 2.21 | Windows 10 Pro (x64) | Linux Mint 19.2 (x64)
"Die Jugend von heute mit ihren Ballerspielen, hocken nur in der Bude - wir haben früher die Leute noch draußen erschossen!"
Bild


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Icon verschwunden
BeitragVerfasst: 13.07.2019 19:36 
Offline

Registriert: 21.01.2008 19:11
Hallo ts-soft!

Ich habe/hatte den relativen Pfad eingetragen.
Ich habe jetzt aber auch mal den absoluten Pfad eingetragen:
es mach keinen Unterschied. Das Icon verschwindet beim
Anheften. :evil:

_________________
Bild


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Icon verschwunden
BeitragVerfasst: 13.07.2019 23:53 
Offline
Benutzeravatar

Registriert: 11.08.2005 19:08
Versuch mal den Icons-Cache zu leeren:
https://www.youtube.com/watch?v=9XJO0wXRFcc

_________________
Bild
Warum OpenSource eine Lizenz haben sollte
PureBasic-CodeArchiv-Rebirth: Git-Repository / Download -- Jede Hilfe ist willkommen!
Manjaro Xfce x64 (Hauptsystem) :: WindowsXP/Xubuntu x86 (VirtualBox) :: PureBasic (Linux: x86/x64, Windows: x86) :: jeweils neueste Version


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Icon verschwunden
BeitragVerfasst: 14.07.2019 09:42 
Offline
Admin
Benutzeravatar

Registriert: 05.10.2006 18:55
Wohnort: Deutschland::Berlin()
Der Youtuber sollte mal seinen Desktop aufräumen. :lol:

_________________
BildBildBildBild(Update: 17.08.2019 (+196 Dateien, +1392 MB)) BildBild


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Icon verschwunden
BeitragVerfasst: 14.07.2019 09:54 
Offline

Registriert: 21.01.2008 19:11
Hallo Sicro!

Sicro hat geschrieben:
Versuch mal den Icons-Cache zu leeren:
https://www.youtube.com/watch?v=9XJO0wXRFcc

Da ich Win7-Nutzer bin, habe ich mich nicht an das Video gehalten.
Aber der Hinweis "Icons-Cache leeren" war ein wichtiger Tip.

So habe ich es gemacht:

1. Taskmanager -> Explorer.exe -> Task beenden
2. Eingabeaufforderung -> "CD /d %userprofile%\AppData\Local"
3. Eingabeaufforderung -> "del iconcache.db /a"
4. Taskmanager -> Neuer Task -> "explorer.exe"

Klappt alles wieder prima.

Danke für den Schubser in die richtige Richtung. :allright:

_________________
Bild


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Icon verschwunden
BeitragVerfasst: 14.07.2019 11:44 
Offline
Benutzeravatar

Registriert: 11.08.2005 19:08
Lord hat geschrieben:
Da ich Win7-Nutzer bin
Oh, sorry, ich habe dein Bild in der Signatur nicht gesehen:
Zitat:
Bild
Weitere Informationen: https://developer.mozilla.org/de/docs/Sicherheit/MixedContent
Kannst du bitte die Bild-URL auf "https://" anpassen?

Lord hat geschrieben:
Danke für den Schubser in die richtige Richtung.
Freut mich, dass ich trotzdem helfen konnte :)

_________________
Bild
Warum OpenSource eine Lizenz haben sollte
PureBasic-CodeArchiv-Rebirth: Git-Repository / Download -- Jede Hilfe ist willkommen!
Manjaro Xfce x64 (Hauptsystem) :: WindowsXP/Xubuntu x86 (VirtualBox) :: PureBasic (Linux: x86/x64, Windows: x86) :: jeweils neueste Version


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Icon verschwunden
BeitragVerfasst: 15.07.2019 10:34 
Offline

Registriert: 21.01.2008 19:11
Sicro hat geschrieben:
...
Kannst du bitte die Bild-URL auf "https://" anpassen?
...
erledigt

_________________
Bild


Nach oben
 Profil  
Mit Zitat antworten  
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 8 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  

 


Powered by phpBB © 2008 phpBB Group | Deutsche Übersetzung durch phpBB.de
subSilver+ theme by Canver Software, sponsor Sanal Modifiye