Aktuelle Zeit: 23.07.2019 00:49

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Forum gesperrt Dieses Thema ist gesperrt. Sie können keine Beiträge editieren oder weitere Antworten erstellen.  [ 7 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: PureBasic 4: Kompabilitätsfrage: GadgetExtensionLibrary
BeitragVerfasst: 04.02.2006 01:05 
Offline

Registriert: 15.09.2004 23:26
Hallo!

Sorry, wieder ein Problem (bin gerade dabei, PB3-Code umzuschreiben).
Beim Kompilieren meckert der Compiler, dass er die GadgetExtension-Library braucht. Wenn ich die von PB3 rüberkopiere, dann meckert er, dass "ButtonImageGadget" doppelt vorhanden ist. Was tun? Soll ich die Gadget- und GadgetExtension-Library von PB3 rüberkopieren und die neue GadgetLibrary dabei ersetzen? Gehen mir dann nicht die neuen Gadget-Befehle flöten?

Gruß, Calloway.


Nach oben
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: 04.02.2006 01:12 
Offline
Benutzeravatar

Registriert: 08.09.2004 00:57
Wohnort: Berlin
Du benutzt wahrscheinlich eine UserLib die nicht PB4 kompatibel ist, Du mußt Dich also zwischen der UserLib und PB4 entscheiden, weil beides nicht geht. Evtl. gibts ja bald ne neue Version, aber wie lange das dauert kann Dir wohl keiner sagen.

_________________
PureBasic 5.70 | SpiderBasic 2.21 | Windows 10 Pro (x64) | Linux Mint 19.1 (x64)
"Die Jugend von heute mit ihren Ballerspielen, hocken nur in der Bude - wir haben früher die Leute noch draußen erschossen!"
Bild


Nach oben
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: 04.02.2006 01:19 
Offline

Registriert: 15.09.2004 23:26
Hmmm... Ist die GadgetExtension nicht eine "offizielle" System-Library von PB3? Wie kriege ich denn heraus, welcher Befehl da querschießt? Der Compiler bricht einfach beim kompilieren ab ohne Hinweis auf die Zeile, an der der Fehler auftrat.


Nach oben
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: 04.02.2006 01:50 
Offline
Benutzeravatar

Registriert: 08.09.2004 00:57
Wohnort: Berlin
Die GadgetExtension ist schon offiziell, aber die Userlib ruft eine Funktion, der 3,94 Version auf, die es in der neuen nicht gibt oder die geändert wurde.
Ich würde erstmal alle UserLibs entfernen, die meisten werden nicht gehen.
Dann kannste ja einzelne ausprobieren, ob sie gehen.

_________________
PureBasic 5.70 | SpiderBasic 2.21 | Windows 10 Pro (x64) | Linux Mint 19.1 (x64)
"Die Jugend von heute mit ihren Ballerspielen, hocken nur in der Bude - wir haben früher die Leute noch draußen erschossen!"
Bild


Nach oben
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: 05.02.2006 00:54 
Offline

Registriert: 15.09.2004 23:26
Frage: Woher weiß PB4, dass ausgerechnet die GadgetExtension-Library fehlt?


Nach oben
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: 05.02.2006 17:56 
Offline
Benutzeravatar

Registriert: 06.08.2005 22:56
Wohnort: Gernsbach
Calloway hat geschrieben:
Wie kriege ich denn heraus, welcher Befehl da querschießt?.


Öffne mal die Library mit einem Texteditor (Notepad.exe von Windows,...).
In der Datei kanst du die Funktionen sehen. NICHT VERÄNDERN!!! :!:

_________________
BildBildBildBild


Nach oben
 Profil  
 
 Betreff des Beitrags:
BeitragVerfasst: 05.02.2006 19:23 
Offline
Benutzeravatar

Registriert: 17.12.2004 20:10
Wohnort: Niederösterreich
Doch nicht die Funktionen, wie ein Mensch sie lesen kann. Ich denke das ist vorkompilierter Binärcode.

_________________
http://www.break.com/index/how_to_prope ... vista.html


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Forum gesperrt Dieses Thema ist gesperrt. Sie können keine Beiträge editieren oder weitere Antworten erstellen.  [ 7 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  

 


Powered by phpBB © 2008 phpBB Group | Deutsche Übersetzung durch phpBB.de
subSilver+ theme by Canver Software, sponsor Sanal Modifiye