Aktuelle Zeit: 17.12.2018 11:48

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 66 Beiträge ]  Gehe zu Seite Vorherige  1 ... 3, 4, 5, 6, 7
Autor Nachricht
 Betreff des Beitrags: Re: PureBasic Doom-like Engine btw. Spiel
BeitragVerfasst: 02.12.2018 21:11 
Offline

Registriert: 27.11.2016 18:13
Wohnort: Erzgebirge
Zu GTK3:

sudo apt-get install gcc g++ libc6-dev libsdl1.2-dev libgtk-3-dev unixodbc-dev libgnome2-dev libxine2-dev libwebkitgtk-3.0-dev libxxf86vm-dev libwebkitgtk-dev libwebkitgtk-3.0-dev

Zu kryptische Zeichen:

Sind die Spracheinstellung bei dir korrekt ? (UTF-8 ?)

Konfigurierbar:

sudo dpkg-reconfigure locales


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: PureBasic Doom-like Engine btw. Spiel
BeitragVerfasst: 03.12.2018 05:39 
Offline
Benutzeravatar

Registriert: 17.10.2010 17:43
Wohnort: Berlin
ccode_new hat geschrieben:
Zu GTK3:

sudo apt-get install gcc g++ libc6-dev libsdl1.2-dev libgtk-3-dev unixodbc-dev libgnome2-dev libxine2-dev libwebkitgtk-3.0-dev libxxf86vm-dev libwebkitgtk-dev libwebkitgtk-3.0-dev

Zu kryptische Zeichen:
naja, da hab ich so meine Probleme ^^
Code:
> sudo apt-get install gcc g++ libc6-dev libsdl1.2-dev libgtk-3-dev unixodbc-dev libgnome2-dev libxine2-dev libwebkitgtk-3.0-dev libxxf86vm-dev libwebkitgtk-dev libwebkitgtk-3.0-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
libsdl1.2-dev ist schon die neueste Version (1.2.15+dfsg1-4).
libxxf86vm-dev ist schon die neueste Version (1:1.1.4-1+b2).
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libgnome2-dev : Hängt ab von: libgnomevfs2-dev soll aber nicht installiert werden
 libgtk-3-dev : Hängt ab von: libgtk-3-0 (= 3.22.11-1) aber 3.22.19-1 soll installiert werden
                Hängt ab von: gir1.2-gtk-3.0 (= 3.22.11-1) aber 3.22.19-1 soll installiert werden
                Hängt ab von: libegl1-mesa-dev soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


ccode_new hat geschrieben:
Sind die Spracheinstellung bei dir korrekt ? (UTF-8 ?)

Konfigurierbar:

sudo dpkg-reconfigure locales
ja sind sie ;)
Code:
> set | grep LC
LC_ALL=de_DE.UTF-8
LC_MESSAGES=de_DE.UTF-8

_________________
PB-Workstation > PureBasic ( win32 Ver. 5.62 ) über Wine 3.0.2
KNOPPIX 8.0.0 ( GNU/Linux-Debian 9 ), 8GB-RAM, AMD-Athlon(tm) II X4 630, AMD Radeon HD 6850


Nichts ist einfacher als das Komplizierteste

Press Any Key to Continue
ich finde aber keine Any Key Taste auf meiner Tastertur

Was steht den auf ihrem Bildschirm
Na eine Blumenvase ...


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: PureBasic Doom-like Engine btw. Spiel
BeitragVerfasst: 03.12.2018 19:15 
Offline

Registriert: 27.11.2016 18:13
Wohnort: Erzgebirge
Meine evtl. Lösungsliste

Wir beseitigen jetzt gemeinsam die aufgeführten Probleme ;)


>Wir schauen nach defekten Paketen.

sudo apt check oder sudo apt-get check

>Wir führen eine Bereinigung durch.

sudo apt autoclean
sudo apt autoremove

>Wir führen ein Update durch.

sudo apt-get upgrade
sudo apt-get update

>Wir versuchen diese Bedingung zu erfüllen:

libgnome2-dev : Hängt ab von: libgnomevfs2-dev soll aber nicht installiert werden

sudo apt-get install libgnomevfs2-dev

>Wir versuchen die nächsten Bedingung zu erfüllen.

libgtk-3-dev:Hängt ab von: libgtk-3-0 (= 3.22.11-1) aber 3.22.19-1 soll installiert werden
Hängt ab von: gir1.2-gtk-3.0 (= 3.22.11-1) aber 3.22.19-1 soll installiert werden
Hängt ab von: libegl1-mesa-dev soll aber nicht installiert werden

Wir probieren:

sudo apt-get install libegl1-mesa-dev
sudo apt-get install libgtk-3-0
sudo apt-get install gir1.2-gtk-3.0

Oder wir installieren die geforderte Version: (3.22.11-1) von z.B. :

https://packages.debian.org/stretch/libgtk-3-0


Viel Spaß!


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: PureBasic Doom-like Engine btw. Spiel
BeitragVerfasst: 05.12.2018 20:41 
Offline
Benutzeravatar

Registriert: 17.10.2010 17:43
Wohnort: Berlin
ccode_new hat geschrieben:
sudo apt-get upgrade
sudo apt-get update

sorry, aber genau diese Befehle führe ich ungern aus, da ich mir mit denen schon einmal mein Knoppix zerschossen habe ^^

von daher warte ich immer bis ich mir nen neuen Satz Festplatten hole, und installiere, das dann aktuelle, Knoppix frisch

aber ein vorhandenes System kriegt bei mir nur die Pflege, die out-of-the-Box funktioniert, ich selbst nachvollziehen kann oder Sicherheitsrelevant ist.

_________________
PB-Workstation > PureBasic ( win32 Ver. 5.62 ) über Wine 3.0.2
KNOPPIX 8.0.0 ( GNU/Linux-Debian 9 ), 8GB-RAM, AMD-Athlon(tm) II X4 630, AMD Radeon HD 6850


Nichts ist einfacher als das Komplizierteste

Press Any Key to Continue
ich finde aber keine Any Key Taste auf meiner Tastertur

Was steht den auf ihrem Bildschirm
Na eine Blumenvase ...


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: PureBasic Doom-like Engine btw. Spiel
BeitragVerfasst: 05.12.2018 20:49 
Offline

Registriert: 27.11.2016 18:13
Wohnort: Erzgebirge
Hallo WSC,

funktioniert den jetzt bei dir GTK 3 ?

Außerdem: Kannst du jetzt die kryptischen Zeichen lesen ?

Ich warte gespannt auf eine Antwort. :)


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: PureBasic Doom-like Engine btw. Spiel
BeitragVerfasst: 06.12.2018 16:12 
Offline
Benutzeravatar

Registriert: 17.10.2010 17:43
Wohnort: Berlin
ccode_new hat geschrieben:
Hallo WSC,

funktioniert den jetzt bei dir GTK 3 ?

Außerdem: Kannst du jetzt die kryptischen Zeichen lesen ?

Ich warte gespannt auf eine Antwort. :)
sorry, aber ich hab innerhalb der woche meißt´ so viel zu tun, das ich nur am Wochenende ´nen Klaren kopf für sowas habe ;)

ansonsten, wegen den kryptischen Zeichen, nein, da hab ich noch keinen Fortschritt gemcht
GTK3 geht wegen obigen Fehlern auch noch nicht, hab es aber iwi auch aufgegeben, da ich angst habe mein System zu zerschiessen

vondaher ist meine anwendung wohl auf kurz oder ( hoffentlich nicht ) lang nur mit DirctX bzw. Wine lauffähig, wobei zumindest bei mir ja auch der WindowedScreen OutputDriver funktioniert hat, virleich haben da noch mehr glück ;)

@ccode_new: was für ein Setup nutzt du ? Windows mit D3D oder OGL oder Linux ?
btw. wenn Linux, hasst du es mal mit dem GTK2 Subsystem oder PureBasic über Wine probiert ?

_________________
PB-Workstation > PureBasic ( win32 Ver. 5.62 ) über Wine 3.0.2
KNOPPIX 8.0.0 ( GNU/Linux-Debian 9 ), 8GB-RAM, AMD-Athlon(tm) II X4 630, AMD Radeon HD 6850


Nichts ist einfacher als das Komplizierteste

Press Any Key to Continue
ich finde aber keine Any Key Taste auf meiner Tastertur

Was steht den auf ihrem Bildschirm
Na eine Blumenvase ...


Nach oben
 Profil  
Mit Zitat antworten  
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 66 Beiträge ]  Gehe zu Seite Vorherige  1 ... 3, 4, 5, 6, 7

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  

 


Powered by phpBB © 2008 phpBB Group | Deutsche Übersetzung durch phpBB.de
subSilver+ theme by Canver Software, sponsor Sanal Modifiye