PureBasic

Forums PureBasic
Nous sommes le Ven 19/Juil/2019 21:49

Heures au format UTC + 1 heure




Poster un nouveau sujet Répondre au sujet  [ 16 messages ]  Aller à la page 1, 2  Suivante
Auteur Message
 Sujet du message: Ajouter les Api supporté par l'éditeur de PB dans jaPBe
MessagePosté: Ven 07/Mai/2004 18:22 
Hors ligne
Avatar de l’utilisateur

Inscription: Mer 28/Jan/2004 20:58
Messages: 4312
Localisation: Clermont ferrand OU Olsztyn
Salut,

j'ai mis jaBPe pour faire des tests, c pas encore au point je trouve mais l'éditeur PB m'énerve un peu à cause de gros problème de bug un peu zarb.

donc donc "PureBasic\Compilers", il y a un fichier "APIFunctionListing.txt"

vous le copiez dans le dossier "jaPBe\Definitions" et vous copier également dans ce dossier mon code qui va traduire le listing d'API pour l'éditeur de PB dans le format des listing jaPBe

Code:
RenameFile("APIFunctionListing.txt", "APIFunctionListing.txt.bak")

If OpenFile(0, "APIFunctionListing.txt.bak")
  If CreateFile(1, "APIFunctionListing.txt")
   
    UseFile(1)
    WriteStringN("/procedure")
   
    Repeat
      UseFile(0)
      Txt.s = ReadString()
     
      Txt1.s = Trim(StringField(Txt, 1, "("))
      Txt2.s = Trim(StringField(Txt, 2, "("))
     
      If Right(Txt1, 1) <> "_"
        Txt1 = Txt1 + "_"
      EndIf
     
      If Txt2
        Txt = Txt1 + " (" + Txt2
      Else
        Txt = Txt1
      EndIf
     
      UseFile(1)
      WriteStringN(Txt)
     
    Until Eof(0)
   
    CloseFile(1)
  EndIf
  CloseFile(0)
  DeleteFile("APIFunctionListing.txt.bak")
EndIf


et voilà, plein d'api intégrer à jaPBe 8)


sinon, d'autres truc si vous ne les avez pas déjà trouver :

je trouvait jaPBe un peu gros, j'ai fait du nettoyage de fichiers "idiots" à mon gout et j'arrive à 1.31 mo
si certains sont intéressés, me demander, moi, je l'ai fait car je trimballe PB et mes codes sur ma clé USB :D

jaPBe n'avait pas les thèmes XP d'activé, mais il suffit de prendre un fichier *.manifest d'un autre exe, de le recopier dans le dossier de jaPBe en le nommant "jaPBe.exe.manifest" et voilà, support des thèmes xp :wink:

_________________
Je ne suis pas à moitié Polonais mais ma moitié est polonaise ... Vous avez suivi ?

[Intel quad core Q9400 2.66mhz, ATI 4870, 4Go Ram, XP (x86) / 7 (x64)]


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 18:35 
Hors ligne
Avatar de l’utilisateur

Inscription: Jeu 22/Jan/2004 14:31
Messages: 3518
Localisation: Sourans
Au fait , c'est quoi jaPBe :mrgreen:

Sinon, j'ai les deux d'installé, mais ja PBe est vraiment plus lent que l'éditeur PB au chargement, éditeur PB qui plante d'ailleurs toujours à la fermeture mais je n'ai plus le problème avec la fenêtre de compilation.


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 18:37 
Hors ligne
Avatar de l’utilisateur

Inscription: Sam 24/Jan/2004 14:54
Messages: 3731
Tu l'as eu comment, ton jaPBe, en pièces détachées ?

J'ai jaPBe depuis déjà pas mal de temps, et il n'a jamais eu besoin de toutes tes bidouilles pour fonctionner, et pour être TRES stable. :?

Chris :)


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 18:41 
Hors ligne
Avatar de l’utilisateur

Inscription: Sam 24/Jan/2004 14:54
Messages: 3731
Denis a écrit:
Au fait , c'est quoi jaPBe :mrgreen:

Sinon, j'ai les deux d'installé, mais ja PBe est vraiment plus lent que l'éditeur PB au chargement, éditeur PB qui plante d'ailleurs toujours à la fermeture mais je n'ai plus le problème avec la fenêtre de compilation.


Normal qu'il soit un peu plus long à charger, puisqu'il charge plus de fichiers que l'éditeur de base, et qu'il a beaucoup plus de fonctions!

Enfin, c'est mon avis, et je suis tout à fait d'accord avec! :lol:

Chris :)


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 18:45 
Hors ligne
Avatar de l’utilisateur

Inscription: Mer 28/Jan/2004 20:58
Messages: 4312
Localisation: Clermont ferrand OU Olsztyn
Citation:
Tu l'as eu comment, ton jaPBe, en pièces détachées ?


ben sur le site données dans les liens sur le site de PB, pourquoi, tu as quel version ?
je suis quand même pas tombé sur une version qui a 30 ans quand même ?

mais, c'est bien la dernière, elle me demande de bien avoir la version 3.90 de Pb d'installer :wink: ou alors j'ai rêver

_________________
Je ne suis pas à moitié Polonais mais ma moitié est polonaise ... Vous avez suivi ?

[Intel quad core Q9400 2.66mhz, ATI 4870, 4Go Ram, XP (x86) / 7 (x64)]


Dernière édition par Le Soldat Inconnu le Ven 07/Mai/2004 18:52, édité 2 fois.

Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 18:48 
Hors ligne
Avatar de l’utilisateur

Inscription: Sam 24/Jan/2004 14:54
Messages: 3731
Ben, la 2.4.5.2 !

Chris :)


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 18:51 
Hors ligne
Avatar de l’utilisateur

Inscription: Mer 28/Jan/2004 20:58
Messages: 4312
Localisation: Clermont ferrand OU Olsztyn
beu, je tomber sur quoi moi ...... ouin ............ :oops:

bon, je la chope où celle la ?
y'a que moi pour arriver à trouver une version qui à 10 ans :0:

_________________
Je ne suis pas à moitié Polonais mais ma moitié est polonaise ... Vous avez suivi ?

[Intel quad core Q9400 2.66mhz, ATI 4870, 4Go Ram, XP (x86) / 7 (x64)]


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 18:54 
Hors ligne
Avatar de l’utilisateur

Inscription: Jeu 29/Jan/2004 0:26
Messages: 2433
Localisation: Nantes
ben là :

http://caosandkin.bei.t-online.de/purebasic/jaPBe/

_________________
Image


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 19:00 
Hors ligne
Avatar de l’utilisateur

Inscription: Mer 28/Jan/2004 20:58
Messages: 4312
Localisation: Clermont ferrand OU Olsztyn
merci :roll:

_________________
Je ne suis pas à moitié Polonais mais ma moitié est polonaise ... Vous avez suivi ?

[Intel quad core Q9400 2.66mhz, ATI 4870, 4Go Ram, XP (x86) / 7 (x64)]


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 19:36 
Hors ligne
Avatar de l’utilisateur

Inscription: Mer 28/Jan/2004 20:58
Messages: 4312
Localisation: Clermont ferrand OU Olsztyn
ben, c'est le même exactement. je l'ai téchargé sur ce site d'ailleur ... 8O

donc mon truc est bien valide.

"pour supporter les Api", il est la le quiproquo, quand je dis ça, je fais référence à l'explication de la fonction en bas de la fenêtre de jaPBe et également quand on commence à taper la fonction, pour qu'elle soit dans la liste des fonctions possibles (pour complèter automatiquement les mots clés). je suis plus clair comme ça :oops:

_________________
Je ne suis pas à moitié Polonais mais ma moitié est polonaise ... Vous avez suivi ?

[Intel quad core Q9400 2.66mhz, ATI 4870, 4Go Ram, XP (x86) / 7 (x64)]


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 19:49 
Hors ligne

Inscription: Mer 21/Jan/2004 17:48
Messages: 5162
Chris a écrit:
Ben, la 2.4.5.2 !


Ah ? j'ai la 1.4.4.25 !

je crois que les deux derniers chiffres correspondent à la date , et les deux premiers à la version , tu ne te serais pas trompé ? c'est pas 1.4.5.2 ?

si c'est bien la 2.4 , j'ai loupé un truc là , parce que je me mets à jour dès que GPI annonce une nouvelle sortie ( pour l'instant je n'ai pas récupéré la version pour la 3.91beta , j'attends la version 3.92)


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 19:49 
Hors ligne
Avatar de l’utilisateur

Inscription: Sam 24/Jan/2004 14:54
Messages: 3731
Mais je l'ai déjà, ça!

C'est pour ça que je comprends pas :lol:

Quand je commence à taper, par exemple GetCursorPos_(), j'ai ça:

Image

et ça:

Image

Chris :)


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 19:53 
Hors ligne
Avatar de l’utilisateur

Inscription: Jeu 29/Jan/2004 0:26
Messages: 2433
Localisation: Nantes
@comtois

Oui tu as effectivement loupé un truc car moi j'ai la 2.4.5.2 depuis disons qq semaines !!!

_________________
Image


Dernière édition par Flype le Ven 07/Mai/2004 19:55, édité 1 fois.

Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 19:54 
Hors ligne
Avatar de l’utilisateur

Inscription: Sam 24/Jan/2004 14:54
Messages: 3731
comtois a écrit:
Chris a écrit:
Ben, la 2.4.5.2 !


Ah ? j'ai la 1.4.4.25 !

je crois que les deux derniers chiffres correspondent à la date , et les deux premiers à la version , tu ne te serais pas trompé ? c'est pas 1.4.5.2 ?

si c'est bien la 2.4 , j'ai loupé un truc là , parce que je me mets à jour dès que GPI annonce une nouvelle sortie ( pour l'instant je n'ai pas récupéré la version pour la 3.91beta , j'attends la version 3.92)


Moi, j'ai récupéré les infos de version dans le panneau "About". Si il y a une erreur, c'est pas ma faute.

Image

(Y va bien, mon petit prog de capture :lol:)

Chris :)


Haut
 Profil  
Répondre en citant le message  
 Sujet du message:
MessagePosté: Ven 07/Mai/2004 20:00 
Hors ligne

Inscription: Mer 21/Jan/2004 17:48
Messages: 5162
c'est étonnant ! ok merci Flype et Chris , je vais me mettre à jour :)


Haut
 Profil  
Répondre en citant le message  
Afficher les messages postés depuis:  Trier par  
Poster un nouveau sujet Répondre au sujet  [ 16 messages ]  Aller à la page 1, 2  Suivante

Heures au format UTC + 1 heure


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages

Rechercher:
Aller à:  
cron

 


Powered by phpBB © 2008 phpBB Group | Traduction par: phpBB-fr.com
subSilver+ theme by Canver Software, sponsor Sanal Modifiye