PureBasic

Forums PureBasic
Nous sommes le Mer 19/Juin/2019 0:10

Heures au format UTC + 1 heure




Poster un nouveau sujet Répondre au sujet  [ 6 messages ] 
Auteur Message
 Sujet du message: Plantage de l'éditeur
MessagePosté: Sam 09/Jan/2010 3:32 
Hors ligne

Inscription: Mer 11/Fév/2004 0:32
Messages: 1015
Localisation: Québec, Canada
Bonjour à tous,

J'ai installé PureBasic version 4.40 (Linux x64) sous Linux Ubuntu 9.10 x64. J'arrive à compiler des codes seulement voilà, l'IDE plante pendant le chargement de certain code source. J'aimerais bien donner les messages d'erreurs il n'y en a aucun.

Exemple d'un projet :

J'essaie d'ouvrir un fichier nommé "PB Bout de Code - Main.pb" qui contient ceci

Code:
; <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
; Nom du projet : PB Bout de Code
; Fichier : Source principal
; Version : 3.1.4
; Programmation : OK
; Programmé par : Guimauve
; Date : 19-11-2006
; Mise à jour : 05-10-2009
; Code PureBasic V4.40 (Window et Linux)
; <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

IncludeFile "SetGadgetItemWithFolderContents.pbi"
IncludeFile "SaveEditorGadgetTextFile.pbi"
IncludeFile "CheckFileExtension.pbi"
IncludeFile "LoopLong.pbi"

IncludeFile "PB Bout de Code - Constantes.pb"

IncludeFile "PB Bout de Code - Options.pb"
IncludeFile "PB Bout de Code - Window.pb"
IncludeFile "PB Bout de Code - TwinState.pb"
IncludeFile "PB Bout de Code - Language.pb"

IncludeFile "PB Bout de Code - PBBoutCode.pb"

; <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
; <<<<< Routine de vérification au lancement du programme <<<<<

InitializePBBoutCode(PBBoutCode.PBBoutCode)

; <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
; <<<<< Ouverture de la fenètre principale du programme <<<<<

OpenPBBoutCodeWindow(PBBoutCode)

; <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
; <<<<< La gestion des évènements <<<<<

PBBoutCodeEventManager(PBBoutCode)

; <<<<<<<<<<<<<<<<<<<<<<<<<<
; <<<<< FIN DU FICHIER <<<<<
; <<<<<<<<<<<<<<<<<<<<<<<<<<


L'IDE se ferme de lui-même sans donner de message d'erreur pendant le chargement. Je relance l'IDE, j'essaie encore d'ouvrir ce fichier et l'IDE se referme de lui-même encore sans donner de message d'erreur. Parfois en ouvrant un autre source au préalable, exemple "LoopLong.pbi", avant d'ouvrir "PB Bout de Code - Main.pb" et bien l'IDE effectue tout les chargements sans problème.

C'est à ni rien comprendre, j'ai bien l'impression que la version 64 bits n'est pas très stable.

A+
Guimauve


Haut
 Profil  
Répondre en citant le message  
 Sujet du message: Re: Plantage de l'éditeur
MessagePosté: Sam 09/Jan/2010 12:38 
Hors ligne
Avatar de l’utilisateur

Inscription: Mar 14/Déc/2004 13:56
Messages: 2659
Localisation: France > Rennes
Essaie de contacter Freak sur le forum anglais. C'est lui qui s'occupe principalement du développement de l'IDE.

Par contre, c'est le compilateur ou l'IDE qui plante ?

_________________
Librairies & Applications : https://www.purebasic.fr/french/viewtopic.php?f=8&t=6220
Site Web : https://rootslabs.net


Haut
 Profil  
Répondre en citant le message  
 Sujet du message: Re: Plantage de l'éditeur
MessagePosté: Sam 09/Jan/2010 14:05 
Hors ligne

Inscription: Mer 11/Fév/2004 0:32
Messages: 1015
Localisation: Québec, Canada
Comme je l'ai mentionné plus haut, l'IDE se ferme de lui-même pendant le chargement du code source. Il se ferme avant même que le code s'affiche dans l'éditeur, j'ai même pas le temps de lancer le compilateur. À mon avis, le problème provient de l'IDE.

Voilà !

A+
Guimauve


Haut
 Profil  
Répondre en citant le message  
 Sujet du message: Re: Plantage de l'éditeur
MessagePosté: Sam 09/Jan/2010 22:34 
Hors ligne
Avatar de l’utilisateur

Inscription: Lun 10/Sep/2007 11:13
Messages: 1311
pas de soucis pour moi , pourrais tu mettre le fichier original sur un serveur car il est peut être corrompu .


par exemple en ayant teste il a sauvé et a ajouté a la fin

; IDE Options = PureBasic 4.40 (Windows - x64)
; CursorPosition = 42
; EnableXP


je devine donc qu'il lis le code lors du chargement et que donc tu as peut être un truc qui vas pas de ce coté la

_________________
ImageImage


Haut
 Profil  
Répondre en citant le message  
 Sujet du message: Re: Plantage de l'éditeur
MessagePosté: Dim 10/Jan/2010 14:53 
Hors ligne

Inscription: Mer 11/Fév/2004 0:32
Messages: 1015
Localisation: Québec, Canada
Bonjour,

Il semble que je n'ai pas été clair, le code en question parfois il passe, parfois il plante. J'ai ouvert les sources en question avec gedit et j'ai viré toute les lignes ou l'éditeur enregistre ces informations. De plus, ce n'est le seul code source qui provoque ce problème, il y en a même des neufs que j'ai codé directement dans Linux à partir de zéro. Exemple de comportement bizarre.

Je sauvegarde un source à un moment, je le ferme puis je l'ouvre à nouveau pour faire des corrections et ça fonctionne, il s'ouvre sans rouspéter. J'ouvre ce source le lendemain et l'IDE plante pendant le chargement. J'ouvre un autre source qui se charge du premier coup, puis je reviens ouvrir le premier source et là il s'ouvre sans planter. 8O

Tiens justement, ce matin j'ai fait un test pour voir et un code qui plantait hier pendant le chargement s'ouvre ce matin sans problème. Le problème est aléatoire c'est pour cette raison que même si je vous envoyais le code source cela ne vous avancera pas. De plus, je travaille sur un projet confidentiel il est donc hors de question que j'affiche le code source en question.

J'ai effectivement eu des soucis avec les anciens codes sources codé originalement sous Windows XP 32 bits, l'encodage des fichiers était l'ASCII sous windows alors que sous Linux l'encodage est UTF-8, alors bien évidemment les caractères accentués posent des problèmes et j'ai forcer la sauvegarde en UTF-8 et j'ai remplacer les caractères incorrects.

J'espère que c'est un peu plus clair.

A+
Guimauve


Haut
 Profil  
Répondre en citant le message  
 Sujet du message: Re: Plantage de l'éditeur
MessagePosté: Dim 10/Jan/2010 23:49 
Hors ligne
Avatar de l’utilisateur

Inscription: Lun 10/Sep/2007 11:13
Messages: 1311
désolé je n'avais pas fait gaffe que tu étais sous linux. donc je ne puis tester de mon coté.

_________________
ImageImage


Haut
 Profil  
Répondre en citant le message  
Afficher les messages postés depuis:  Trier par  
Poster un nouveau sujet Répondre au sujet  [ 6 messages ] 

Heures au format UTC + 1 heure


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages

Rechercher:
Aller à:  

 


Powered by phpBB © 2008 phpBB Group | Traduction par: phpBB-fr.com
subSilver+ theme by Canver Software, sponsor Sanal Modifiye