PureBasic

Forums PureBasic
Nous sommes le Dim 20/Oct/2019 9:47

Heures au format UTC + 1 heure




Poster un nouveau sujet Répondre au sujet  [ 2 messages ] 
Auteur Message
 Sujet du message: Soucis d'images et de profil couleur
MessagePosté: Mer 26/Sep/2012 20:17 
Hors ligne
Avatar de l’utilisateur

Inscription: Lun 10/Sep/2012 11:55
Messages: 103
Localisation: France - 89220 Rogny-Les-Septs-Ecluses
Bonjour,

Essayant d'harmoniser une interface sur les 3 plateformes Windows, Linux et Mac OS X, je suis confronté à petit soucis sur le Mac que j'essaye de comprendre.

Voici deux captures d'écran:

Image
Image

La première est sous Windows mais j'ai exactement le même résultat sous Linux.

La deuxième est sur Mac et l'on peut constater 2 problèmes:
- Un soucis avec DrawImage sur la partie centrale de mes boutons, aucune idée d'où cela peut venir.
- Un soucis avec les couleurs générales, c'est tout délavé, comme si le Mac appliquait un profil de couleur qui ne correspond pas aux images originales.

Pour le premier problème je n'ai donc aucune idée, y-a-t-il une subtilité à connaître pour que le Mac daigne m'afficher les images correctement ?

Pour le deuxième problème, j'imagine qu'il s'agit d'une histoire de profil de couleurs, est-ce qu'il y a moyen de 'forcer' un profil de couleur dans une application Mac ? Mes images et couleurs sont calibrées pour du sRGB mais quand je choisi ce profil sRGB dans les réglages du Mac c'est encore pire, on dirait qu'il considère que mes images/couleurs sont en linéaire et donc qu'il applique son profil sRGB, donc 2x sRGB d'appliqué, ce qui délave le tout.

Voilà, si quelqu'un peut m'aider là dessus, ce serait sympa.

Cordialement,
Guy.

_________________
guy rabiller | radfac founder / ceo | raa.tel | raafal.org


Haut
 Profil  
Répondre en citant le message  
 Sujet du message: Re: Soucis d'images et de profil couleur
MessagePosté: Mer 26/Sep/2012 20:35 
Hors ligne
Avatar de l’utilisateur

Inscription: Lun 10/Sep/2012 11:55
Messages: 103
Localisation: France - 89220 Rogny-Les-Septs-Ecluses
Je compilais sans mettre l'extension *.app

J'ai rajouté cette extension dans l'IDE pour produire l’exécutable et du coup, les couleurs sont bonnes.. (c'est mystérieux le Mac pour moi ;))

Par contre ça n'a pas réglé le problème d'affichage des images.

_________________
guy rabiller | radfac founder / ceo | raa.tel | raafal.org


Haut
 Profil  
Répondre en citant le message  
Afficher les messages postés depuis:  Trier par  
Poster un nouveau sujet Répondre au sujet  [ 2 messages ] 

Heures au format UTC + 1 heure


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages

Rechercher:
Aller à:  

 


Powered by phpBB © 2008 phpBB Group | Traduction par: phpBB-fr.com
subSilver+ theme by Canver Software, sponsor Sanal Modifiye