PureBasic
https://www.purebasic.fr/french/

PlayModule() ne fonctionne pas et grésille fort
https://www.purebasic.fr/french/viewtopic.php?f=16&t=10996
Page 1 sur 2

Auteur:  heliuse [ Mar 21/Sep/2010 17:24 ]
Sujet du message:  PlayModule() ne fonctionne pas et grésille fort

Bonjour,
Je suis l'ancien Marcus mais reconnecté heliuse car perdu le pass et mail correspondant a un vieux compte perdu aussi .
je n'arrive pas a lire un mod ou xm avec pure basic osx 1.6.4
le son grésille grave :(
sos MErci

Auteur:  G-Rom [ Mer 22/Sep/2010 19:57 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

hooo , Marcus , il me semblait bien que je reconnaissais ton avatar !
tu es de retour sur PB ? toujours dans le dev de jeux amateur ?

Auteur:  Backup [ Mer 22/Sep/2010 20:03 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

c'est qui ce Marcus ?

connais pas ! 8O

en plus il est sous Mac ? pffff! n'importe quoi ! :mrgreen:

ce ne serai pas un problème de Codec ton histoire ?

Auteur:  G-Rom [ Mer 22/Sep/2010 20:05 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

Tu pédales dans la semoule Dobro ? :mrgreen:
http://www.purebasic.fr/french/viewtopic.php?f=2&t=4147

Auteur:  Backup [ Jeu 23/Sep/2010 0:08 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

G-Rom a écrit:


mais non :lol;
Marcus sait tres biens que je me souviens de lui :)

c'etait une blague ... ;)

Auteur:  heliuse [ Jeu 23/Sep/2010 7:58 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

Bonjour à vous Tous :)
Content que vous soyez toujours là , super :D

Entre temps j'ai personnellement "joué" avec d'autres languages ,
comme MMF2 avec lequel j'ai réalisé un petit jeu Orbit :
http://spoke2018.homelinux.com/download/orbit.zip
en version non accélérée hardware cette dernière est restée sur le grill .
aussi du GLbasic auquel j'ai traduit la doc en FR ,
codé mon Puckman et POker sur GP2x et Wizz:
http://dl.openhandhelds.org/cgi-bin/gp2 ... ,0,27,2588
http://dl.openhandhelds.org/cgi-bin/gp2 ... ,0,25,2556
et un nouveau Poker pour windows :
http://www.glbasic.com/data/games/poker.zip

Vous moquez pas trop mais oui je suis passé a osx , je suis sorti de l'amiga ,et + de 10 ans de windows pour nous sortir un 7 qui ne respecte toujours pas la priorité a l'affichage .
Je re bave enfin devant du vrai fluide sans aucun micro freez avec pure sur osx :D ca fait du bien .
Donc voila je cherche comment jouer des mod en pure sur osx ou alors du mp3 ou ogg (ca j'y arrive ) mais pas en boucle ni régler le volume .

Merci à vous ,bon code en Pure ,les bonnes chose on y revient :mrgreen:

Auteur:  G-Rom [ Jeu 23/Sep/2010 9:48 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

Pourquoi tu ne viens pas sous Linux ?
tu vas être un pionner sur mac/os & PB , mis à part Fred , je ne pourrais pas t'aider.
En parlant de Mac , j'ai cru comprendre qu'il pouvait tourné sur x86 ? c'est vrai ? y a t'il une différence avec le power pc ?

Auteur:  Mindphazer [ Jeu 23/Sep/2010 11:09 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

Non seulement Mac OS X tourne sur x86, mais en plus la dernière version du système ne tourne que sous x86 !!
Le PPC a été abandonné par Apple à partir de Snow Leopard

La principale différence avec le PPC c'est que tu peux, moyennant quelque bricolage, de monter un "hackintosh", c'est à dire faire tourner Mac OS X sur une machine PC...

Auteur:  heliuse [ Jeu 23/Sep/2010 11:18 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

G-Rom: j'ai encore testé dernièrement ubuntu mais bon chacun ses gouts :wink:
osx me correspond mieux en terme de qualité d'affichage :mrgreen:
ici osx marche sur un core2 intel , j'ai jamais eu de ppc .
Mindphazer: "hackintosh" a bon!? c'est quoi cette bête :mrgreen:

Auteur:  Backup [ Jeu 23/Sep/2010 11:28 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

heliuse a écrit:
aussi du GLbasic auquel j'ai traduit la doc en FR


t'as un lien ?? :)


ps: ce lien ne fonctionne pas chez moi :
http://spoke2018.homelinux.com/download/orbit.zip

Auteur:  heliuse [ Jeu 23/Sep/2010 12:36 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

Dopro: " ps: ce lien ne fonctionne pas chez moi :"
désolé le copain Spoke à du vider son serveur, j'essaierai de le remetter

Dopro: "t'as un lien ?? :)"
je suis pas la pour faire de la pub pour un autre basic surtout que celui ci est bien pour coder sur iphone gp2x wizz ...
Mais pour windows le Pure est bien plus optimisé . :)
la doc que j'ai traduite en fr du glbasic :
http://www.glbasic.com/files/GLBasic_fr.chm
il compile aussi osx mais bon c'est du béta à mon gout :?
J'espère que je pouvais m'amuser avec le Pure sous Osx qui me semble plus evolué .
je cherche encore comment lire du mod ou manipuler facilement les mp3 ou ogg ( volume , boucle ..)
pour pouvoir développer un nouveau petit jeu . :mrgreen:

ps: installez osx y'en a mare de dober :mrgreen: ... ok de sort

Auteur:  Fred [ Jeu 23/Sep/2010 13:48 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

Je vais regarder pour le mod, y'a peut etre une histoire de littleendian, vu que j'avais tester à l'origine sur powerpc

Auteur:  Backup [ Jeu 23/Sep/2010 14:09 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

heliuse a écrit:
je suis pas la pour faire de la pub pour un autre basic


Merci , toutefois il n'y a pas de mal a se renseigner :)

il compile sous linux.. je crois.. :)

Auteur:  heliuse [ Jeu 23/Sep/2010 15:10 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

compiler sous windows pour linux oui ca marche .
sinon ya pas d'ide linux c'est du wine :roll:
de plus c'est lent et limité comme basic comparé au pure .
Je l'ai trouvé intéressant pour jouer avec la gp2x et la wizz .
Ça compile aussi pour osx (soit disant ) mais j'ai pas réussi à exécuter .
donc ici ça Pure :mrgreen:

Merci Fred de regarder pour les mod :)

Auteur:  Mindphazer [ Mar 28/Sep/2010 13:31 ]
Sujet du message:  Re: PlayModule() ne fonctionne pas et grésille fort

heliuse a écrit:
Mindphazer: "hackintosh" a bon!? c'est quoi cette bête :mrgreen:


Tu trouveras plein de choses ici :
http://www.mac-on-pc.fr

Page 1 sur 2 Heures au format UTC + 1 heure
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/