PureBasic
https://www.purebasic.fr/french/

Tailbite
https://www.purebasic.fr/french/viewtopic.php?f=12&t=11629
Page 1 sur 1

Auteur:  Droopy [ Jeu 17/Mar/2011 22:04 ]
Sujet du message:  Tailbite

Bonjour

Je sollicite votre aide et vos connaissances en asm pour corriger un bug sur Tailbite http://www.tailbite.com/

Depuis la version 4.10 il y a un bug lors du passage de pararamètres cf : http://forums.purebasic.com/english/vie ... 1432a680d9

Le code source est fourni avec tailbite

Cordialement

Auteur:  djes [ Jeu 17/Mar/2011 22:15 ]
Sujet du message:  Re: Tailbite

Pas compris. C'est bien le bon lien? C'est pas un bug de debug?

Auteur:  Droopy [ Jeu 17/Mar/2011 22:30 ]
Sujet du message:  Re: Tailbite

Je reformule donc :

Tailbite bugue quand une fonction accepte un .s en entrée et retourne un .s
Cela se produit quand on passe une fonction en entrée, comme dans l'exemple cité ci-dessus.

Auteur:  PAPIPP [ Jeu 17/Mar/2011 23:12 ]
Sujet du message:  Re: Tailbite

Bonjour Droopy
Code:
ProcedureDLL.s TestStr(InputStr.s)
   ProcedureReturn InputStr
EndProcedure


Citation:
First I Build it To userlib by tailbite,then I CALL it IN Next application,For Example:

Traduction
c'est un problème connu, vous devez utiliser une variable pour contenir le résultat de l'appel de fonction.
BR Klaus



BB Klaus est le responsable de Tailbite
Toutefois ce bug n'est toujours pas corrigé il faut toujours placer la chaine dans une variable avant d'appeler la fonction
Code:
  InputStr.s="hello123"
  Debug TestStr(InputStr)

ou comme cela
Code:
  Debug TestStr("hello 123")

et non comme cela
Code:
   InputStr.s="hello"
  Debug TestStr(InputStr+"123")

@+

Auteur:  Droopy [ Jeu 17/Mar/2011 23:30 ]
Sujet du message:  Re: Tailbite

Bonsoir PAPIPP,

J'ai vu ce contournement, et suis à la recherche de quelqu'un pouvant résoudre ce bug
ABKlaus / Lexvitory / Gnozal ne semblent pas pouvoir corriger ce bug, c'est pourquoi j'ai posté ici

Auteur:  Droopy [ Ven 18/Mar/2011 0:03 ]
Sujet du message:  Re: Tailbite

un autre thread qui explique le soucis : http://www.purebasic.fr/english/viewtop ... 13&t=30840

Page 1 sur 1 Heures au format UTC + 1 heure
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/