It is currently Mon Sep 23, 2019 8:56 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Initsprite not work anymore on my pc
PostPosted: Mon Jun 24, 2019 10:01 am 
Offline
User
User

Joined: Fri Jul 29, 2005 11:47 am
Posts: 52
Dear all, i've a windows 7 x64 installation, from some days the command initsprite fail without any reason, how i can debug and solve the problem ? i've some personal purebasic application that does not work anymore! i try to reinstall directx package but this does not solve the problem, please help me! Thanks!


Top
 Profile  
Reply with quote  
 Post subject: Re: Initsprite not work anymore on my pc
PostPosted: Mon Jun 24, 2019 8:09 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Sun Sep 11, 2016 2:17 pm
Posts: 520
Sounds like a driver issue.
Try it with OpenGL as Subsystem.


Top
 Profile  
Reply with quote  
 Post subject: Re: Initsprite not work anymore on my pc
PostPosted: Mon Jun 24, 2019 9:08 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 1915
Location: Germany
Sometimes the same problem and i use subsystem OpenGL too

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: Initsprite not work anymore on my pc
PostPosted: Tue Jun 25, 2019 7:50 am 
Offline
Addict
Addict
User avatar

Joined: Wed Apr 30, 2003 8:15 am
Posts: 983
Location: Germany
.

_________________
"Daddy, I'll run faster, then it is not so far..."


Last edited by dige on Wed Jun 26, 2019 6:59 am, edited 1 time in total.

Top
 Profile  
Reply with quote  
 Post subject: Re: Initsprite not work anymore on my pc
PostPosted: Tue Jun 25, 2019 11:43 am 
Offline
User
User

Joined: Fri Jul 29, 2005 11:47 am
Posts: 52
on this pc works until latest windows updates, i notice also a strange thing, if i run dxdiag the first time tell me that test are in x86 subsystem and i can switch to x64 subsystem also, the dxdiag tell that in x86 subsystem directx does not work, instead works on x64 subsystem, what the hell ?


Top
 Profile  
Reply with quote  
 Post subject: Re: Initsprite not work anymore on my pc
PostPosted: Wed Jun 26, 2019 9:28 am 
Offline
User
User

Joined: Fri Jul 29, 2005 11:47 am
Posts: 52
Just a little update, i've done this test, creating 2 executable with purebasic x86 and purebasic x64, that return in messagerequester the result of initsprite command.

x86 return 0
x64 return 1

that is the exact result that i see in dxdiag, now on some forum users write that x86 directx subsystem need to be enabled manually, but dxdiag does not have any option like this, and some weeks ago x86 directx subsystem does not have this problem on this pc, anyone can help me to solve this problem ?


Top
 Profile  
Reply with quote  
 Post subject: Re: Initsprite not work anymore on my pc
PostPosted: Wed Jun 26, 2019 10:51 am 
Offline
Addict
Addict

Joined: Sun Jun 25, 2006 7:28 pm
Posts: 1368
i suggest to download the full DX9 year 2010 directly from microsoft (98MB)
http://download.microsoft.com/download/ ... redist.exe
then extract the files somewhere
i have noticed half of the files is for x86 and the others for x64 like this
Aug2009_d3dx10_42_x86
Aug2009_d3dx10_42_x64

then run DXSETUP.exe to install dx9. i suggest to disable the web access during the offline install we don't know what micrsoft does when you are online.

then try first one of the purebasic examples which are using InitSprite()
tell us what happened
if that does not work, i remember in the past when i have installed DX9 year 2007 version have cured the problem on windows 7 but now i am preferring to use windows xp/32
the DX9 nov. 2007 can be downloaded from (64MB)
http://filehippo.com/download_directx/3345/
after installing this reinstall DX9 year 2010 over it


Top
 Profile  
Reply with quote  
 Post subject: Re: Initsprite not work anymore on my pc
PostPosted: Wed Jun 26, 2019 11:09 am 
Offline
Enthusiast
Enthusiast

Joined: Mon Apr 10, 2017 6:17 pm
Posts: 270
Location: Germany
I am running win7x64 on one machine too. If you supply a basic complete source example that doesnt work on your machine, i will try to get it to work on mine and see if/where it breaks so you know what to fix :)

Keep it as simple as possible - that also means : use a 64bit compiler and resulting binaries, because a 32bit executable would require the whole WOW64 overhead.

I just tried both 2d sprite examples from the PureBasic manual on my windows7 x64 machine and both worked without any problems with OpenGL.

When i explicitly selected the DirectX11 subsystem with the sprite.pb example, InitSprite() actually fails, but i never manually installed any directx support on the machine plus i used the x86 compiler.

_________________
webpage


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye