It is currently Wed Dec 02, 2020 11:17 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: [5.72 LTS] IDE not responsive
PostPosted: Wed Apr 01, 2020 5:34 pm 
Offline
Addict
Addict

Joined: Thu Jun 07, 2007 3:25 pm
Posts: 3965
Location: Berlin, Germany
In the final release of PB 5.72 LTS for Windows (at least in the x64 version), there is a very nasty bug in the IDE: It happens rather often here (on Windows 10) that it's not possible anymore to resize or terminate the IDE. This happened when the IDE is minimized, and also when it is maximized. Also mouse clicks at the main menu and at the toolbar don't have any effect.
I have never encountered something similar before in previous PB releases (on Windows).

_________________
Please excuse my flawed English. My native language is PureBasic.
Search
RSBasic's backups


Top
 Profile  
Reply with quote  
 Post subject: Re: [5.72 LTS] IDE not responsive
PostPosted: Wed Apr 01, 2020 5:53 pm 
Offline
Addict
Addict
User avatar

Joined: Wed Dec 23, 2009 10:14 pm
Posts: 3347
Location: Boston, MA
No problems here: Windows 10 Pro v1909, 6.3.18363.720
What are the steps to reproduce?

_________________
The nice thing about standards is there are so many to choose from. ~ Andrew Tanenbaum


Top
 Profile  
Reply with quote  
 Post subject: Re: [5.72 LTS] IDE not responsive
PostPosted: Wed Apr 01, 2020 6:06 pm 
Offline
Addict
Addict

Joined: Thu Jun 07, 2007 3:25 pm
Posts: 3965
Location: Berlin, Germany
skywalk wrote:
What are the steps to reproduce?

At the moment, I don't know. It seems to happen "out of the blue".

_________________
Please excuse my flawed English. My native language is PureBasic.
Search
RSBasic's backups


Top
 Profile  
Reply with quote  
 Post subject: Re: [5.72 LTS] IDE not responsive
PostPosted: Mon Apr 13, 2020 12:58 pm 
Offline
Addict
Addict

Joined: Wed Nov 12, 2008 5:01 pm
Posts: 1129
Location: Russia
I confirm.
In some circumstances, the IDE freezes.

_________________
Library XP_Menu_Lib - office menu; HID_Lib - USB Library
Torrent client - pbTorrent (source code); Create driver in PureBasic.


Top
 Profile  
Reply with quote  
 Post subject: Re: [5.72 LTS] IDE not responsive
PostPosted: Mon Apr 20, 2020 8:09 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Oct 06, 2006 4:41 am
Posts: 725
Location: Canada
I, too, have encountered this nasty problem. The IDE suddenly, for no immediately identifiable reason, just stops responding.

Is this a PB bug, or a Windows one ?

I'm running PB 5.72 in Windows 10 X64 2004, build 19041.207

As well, the IDE loads up blank. It seems to have suddenly forgotten its history, even though the files in the roaming folder (History, tools, preferences) appear intact. The list of recent files also appears accurate.

_________________
"That's not a bug..." said the programmer. "...It's a feature! "
"Oh! I see..." replied the blind man.


Top
 Profile  
Reply with quote  
 Post subject: Re: [5.72 LTS] IDE not responsive
PostPosted: Mon Apr 20, 2020 10:01 pm 
Offline
Addict
Addict

Joined: Thu Apr 18, 2019 8:17 am
Posts: 1093
I hope this isn't a sign of things to come due to the IDE being open-source now? My fear is that people are making changes that are accidentally breaking things behind the scenes.


Top
 Profile  
Reply with quote  
 Post subject: Re: [5.72 LTS] IDE not responsive
PostPosted: Thu May 14, 2020 11:32 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Thu Nov 26, 2015 6:52 pm
Posts: 189
Location: Italy
I haven't experience the above mentioned problems with the latest IDE release, and I also work on Win 10 x64.

The fact that it's affecting some users and not others might indicate some common hardware which might be incompatible (or trig the bug) — e.g. do you work with multiple monitors?

It could be a problem related to DPI awareness, since it's affecting window resizing/minimizing operations.

If it was an IDE bug, probably every Win user would be experiencing it. But since it only affects some machines, it might be a PB bug.

_________________
The PureBASIC Archives:
FOSS Resources:


Top
 Profile  
Reply with quote  
 Post subject: Re: [5.72 LTS] IDE not responsive
PostPosted: Thu May 14, 2020 11:59 pm 
Offline
Enthusiast
Enthusiast

Joined: Mon Apr 10, 2017 6:17 pm
Posts: 395
Location: Germany
I never experienced that on win7 ultimate x64.

_________________
webpage


Top
 Profile  
Reply with quote  
 Post subject: Re: [5.72 LTS] IDE not responsive
PostPosted: Fri May 15, 2020 12:57 am 
Offline
Addict
Addict

Joined: Thu Jun 07, 2007 3:25 pm
Posts: 3965
Location: Berlin, Germany
BarryG wrote:
My fear is that people are making changes that are accidentally breaking things behind the scenes.
That's my fear, too.

_________________
Please excuse my flawed English. My native language is PureBasic.
Search
RSBasic's backups


Top
 Profile  
Reply with quote  
 Post subject: Re: [5.72 LTS] IDE not responsive
PostPosted: Tue May 19, 2020 9:42 am 
Online
Administrator
Administrator

Joined: Fri May 17, 2002 4:39 pm
Posts: 14180
Location: France
I guess it's a whole new process, we are also reviewing the new code before pushing it to the main branch, so we need to get better at it to avoid such issues :)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye