It is currently Mon Sep 16, 2019 9:44 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: FlipBuffers issue
PostPosted: Wed Aug 21, 2019 4:20 pm 
Offline
User
User
User avatar

Joined: Tue Oct 06, 2009 9:11 pm
Posts: 87
I'm having trouble with OpenScreen() and WindowedScreens(): Flipbuffers() causes an memory error. (tested with the original "WindowedScreen" PB Example). I reinstalled PB5.71 and also disabled my antivir program but that's not causing the issue.

Greetings A.D.

*please read posting #4

_________________
Repeat
PureBasic
ForEver


Last edited by A.D. on Wed Aug 21, 2019 11:08 pm, edited 3 times in total.

Top
 Profile  
Reply with quote  
 Post subject: Re: problems since Windows Update 1903
PostPosted: Wed Aug 21, 2019 4:42 pm 
Offline
Addict
Addict
User avatar

Joined: Wed Dec 23, 2009 10:14 pm
Posts: 3054
Location: Boston, MA
No problems here with PB v571 LTS x64 on latest Windows 10 Pro x64 v1903 build 18362.295.
Using Windowed Screen example file.

_________________
The nice thing about standards is there are so many to choose from. ~ Andrew Tanenbaum


Top
 Profile  
Reply with quote  
 Post subject: Re: problems since Windows Update 1903
PostPosted: Wed Aug 21, 2019 6:58 pm 
Offline
User
User
User avatar

Joined: Tue Oct 06, 2009 9:11 pm
Posts: 87
could somebody do me a favor and compile the Windowed Screen Example and upload it for me, please!

_________________
Repeat
PureBasic
ForEver


Top
 Profile  
Reply with quote  
 Post subject: Re: problems since Windows Update 1903
PostPosted: Wed Aug 21, 2019 9:29 pm 
Offline
User
User
User avatar

Joined: Tue Oct 06, 2009 9:11 pm
Posts: 87
i investigated a little bit more and i found out that the issue occurs only when i am using Purebasic5.71_x64. I installed the x86 version and everything works fine. Maybe it's a PureBasic5.71_x64 LTS bug but not for sure.

the compiler tells me "invalid memory access (read error at adress 420167560) with FlipBuffers() command.

*update: when i choose as subsystem OpenGL with PB5.71_x64 the example is running without any error.... I checked DirectX with dxdiag.exe and it tells me there are no problems. this is weird, isn't it?

_________________
Repeat
PureBasic
ForEver


Top
 Profile  
Reply with quote  
 Post subject: Re: FlipBuffers issue
PostPosted: Thu Aug 22, 2019 12:09 am 
Offline
Addict
Addict
User avatar

Joined: Wed Dec 23, 2009 10:14 pm
Posts: 3054
Location: Boston, MA
It's weird you did not read my reply :idea:

_________________
The nice thing about standards is there are so many to choose from. ~ Andrew Tanenbaum


Top
 Profile  
Reply with quote  
 Post subject: Re: FlipBuffers issue
PostPosted: Thu Aug 22, 2019 11:00 am 
Offline
User
User
User avatar

Joined: Tue Oct 06, 2009 9:11 pm
Posts: 87
i read your post, skywalk. The question is what could be broken on my system so that x64 won't work properly but x86 does and how to repair it.

_________________
Repeat
PureBasic
ForEver


Top
 Profile  
Reply with quote  
 Post subject: Re: FlipBuffers issue
PostPosted: Thu Aug 22, 2019 12:19 pm 
Offline
Addict
Addict
User avatar

Joined: Wed Dec 23, 2009 10:14 pm
Posts: 3054
Location: Boston, MA
I was referring to your claim that it might be an x64 PB bug after I said the code worked for me. :?:
I will post an exe of the example for you to try when I am near a computer.

_________________
The nice thing about standards is there are so many to choose from. ~ Andrew Tanenbaum


Top
 Profile  
Reply with quote  
 Post subject: Re: FlipBuffers issue
PostPosted: Thu Aug 22, 2019 3:26 pm 
Offline
User
User
User avatar

Joined: Tue Oct 06, 2009 9:11 pm
Posts: 87
yes, i also think something is messed up with my DirectX after the update to 1903, but maybe the problem is related to v1903, purebasic and different hardware setups, who knows :-)

_________________
Repeat
PureBasic
ForEver


Top
 Profile  
Reply with quote  
 Post subject: Re: FlipBuffers issue
PostPosted: Thu Aug 22, 2019 5:23 pm 
Offline
Addict
Addict
User avatar

Joined: Wed Dec 23, 2009 10:14 pm
Posts: 3054
Location: Boston, MA
7-zip of my working exe

_________________
The nice thing about standards is there are so many to choose from. ~ Andrew Tanenbaum


Top
 Profile  
Reply with quote  
 Post subject: Re: FlipBuffers issue
PostPosted: Thu Aug 22, 2019 5:49 pm 
Offline
User
User
User avatar

Joined: Tue Oct 06, 2009 9:11 pm
Posts: 87
thx skywalk, your compilation is not running correctly on my system. I would be grateful, if anybody knows how to fix this so i don't need to setup a new win installation. When running the exe Windows reports an error message "werfault.exe" in combination with MS Visual C++ 2017 Redistributable.

_________________
Repeat
PureBasic
ForEver


Top
 Profile  
Reply with quote  
 Post subject: Re: FlipBuffers issue
PostPosted: Fri Aug 23, 2019 10:20 am 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Sat Feb 19, 2011 10:06 am
Posts: 775
Location: Denmark
A.D. wrote:
thx skywalk, your compilation is not running correctly on my system. I would be grateful, if anybody knows how to fix this so i don't need to setup a new win installation. When running the exe Windows reports an error message "werfault.exe" in combination with MS Visual C++ 2017 Redistributable.

I have a hard time believing that the problem is related to Purebasic.
Have you tried turning off werfault.exe to see if the problem persists?

http://windows-exe-errors.com/how-to-di ... n-windows/

_________________
“Tell me and I forget. Teach me and I remember. Involve me and I learn.”
— Benjamin Franklin
Current configurations: Windows 7/10, Intel 6800K, Gtx 970, 32 gb ram.


Top
 Profile  
Reply with quote  
 Post subject: Re: FlipBuffers issue
PostPosted: Fri Aug 23, 2019 10:45 am 
Offline
User
User
User avatar

Joined: Tue Oct 06, 2009 9:11 pm
Posts: 87
yes, i tried this...this is what i already have done:

- sfc /scannow
- dism
- chdksk
- memory test (100% ok)
- checked DX with DXDiag.exe (100%)
- shutdown of WerFault-Service in System Control
- reinstalled Visual C++ 2015/2017 Redistributable
- reinstalled Purebasic
- reinstalled nvidia driver with DDU.exe
- virus scan (no infections) / disabled antivirus app

_________________
Repeat
PureBasic
ForEver


Top
 Profile  
Reply with quote  
 Post subject: Re: FlipBuffers issue
PostPosted: Fri Aug 23, 2019 12:01 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Sun Sep 11, 2016 2:17 pm
Posts: 512
Do you have multiple monitors or recording/profiling software that
could automatically hook into the renderer?


Top
 Profile  
Reply with quote  
 Post subject: Re: FlipBuffers issue
PostPosted: Fri Aug 23, 2019 12:28 pm 
Offline
Addict
Addict

Joined: Sun Jun 25, 2006 7:28 pm
Posts: 1369
A.D. , install DX9 again, look my post here:
viewtopic.php?f=7&t=73083#p538455
since the ALAN does not reply i suppose it works.


Top
 Profile  
Reply with quote  
 Post subject: Re: FlipBuffers issue
PostPosted: Fri Aug 23, 2019 1:22 pm 
Offline
User
User
User avatar

Joined: Tue Oct 06, 2009 9:11 pm
Posts: 87
unfortunately installing them didn't fix the issue

_________________
Repeat
PureBasic
ForEver


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye