It is currently Thu Dec 13, 2018 2:48 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: PB 5.62-5.70 Interfaces inside structures IMA
PostPosted: Wed Aug 22, 2018 11:16 pm 
Offline
Enthusiast
Enthusiast

Joined: Sat Apr 26, 2003 2:49 pm
Posts: 572
The code shows the problem, i think it has something to do with the first interface param being a p-bstr, redefining it as an integer and using SysAllocString() to pass a bstr works.
I think it happens only in 64 bit.
Code:
EnableExplicit

Define.IWebbrowser wb

Structure TEST
   wb.IWebBrowser
EndStructure

Define.TEST t

OpenWindow(0, 0, 0, 600, 300, "WebGadget", #PB_Window_SystemMenu | #PB_Window_ScreenCentered | #PB_Window_MaximizeGadget)
WebGadget(0, 10, 10, 580, 280, "")
t\wb = GetWindowLongPtr_(GadgetID(0), #GWL_USERDATA)
wb = GetWindowLongPtr_(GadgetID(0), #GWL_USERDATA)

t\wb\Navigate("google.com", 0, 0, 0, 0) ;IMA
; wb\Navigate("google.com", 0, 0, 0, 0) ;WORKS

Repeat
Until WaitWindowEvent() = #PB_Event_CloseWindow


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye