It is currently Sat Oct 19, 2019 2:16 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: PB5.1b4 - IDE folding indicator not updated
PostPosted: Sat Jan 19, 2013 11:26 pm 
Offline
Addict
Addict

Joined: Thu Nov 01, 2007 5:37 pm
Posts: 1981
Location: Germany
Whenever I delete larger code parts which are folded, the indicator line(s) on the left refuse to update properly. Toggling it with F4 doesn't help either... Here is a quick example image:
Image

_________________
If any of you native English speakers have any suggestions for the above text, please let me know (via PM). Thanks!


Top
 Profile  
Reply with quote  
 Post subject: Re: PB5.1b4 - IDE folding indicator not updated
PostPosted: Sun Jan 20, 2013 2:44 am 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jan 12, 2009 10:33 am
Posts: 461
Confirmed, I have experienced the same issue with beta 4.

_________________
Intel Core i7 Quad 2.3 Ghz, 8GB RAM, GeForce GT 630M 2GB, Windows 10 (x64)


Top
 Profile  
Reply with quote  
 Post subject: Re: PB5.1b4 - IDE folding indicator not updated
PostPosted: Sun Jan 20, 2013 9:26 am 
Offline
Addict
Addict

Joined: Fri Nov 09, 2012 11:04 pm
Posts: 1681
Location: Uttoxeter, UK
PB510-b4 and Windows 7-64-bit.

Persistent vertical line left after deleting a procedure; doesn't matter if its closed or open.
If another procedure written by the | it pokes through the + or - depending upon whether the procedure is open or closed.

I seem to recall this happening with 5.00 through 5.10b4

I work round this by closing PB! and then re-running it.

Looks like this after a while!:


|


|

_________________
DE AA EB


Top
 Profile  
Reply with quote  
 Post subject: Re: PB5.1b4 - IDE folding indicator not updated
PostPosted: Thu Aug 15, 2013 10:52 pm 
Offline
Administrator
Administrator

Joined: Fri May 17, 2002 4:39 pm
Posts: 13622
Location: France
Does it still happen ? Could you post the steps to repoduce it ?


Top
 Profile  
Reply with quote  
 Post subject: Re: PB5.1b4 - IDE folding indicator not updated
PostPosted: Fri Aug 16, 2013 1:11 am 
Offline
Addict
Addict
User avatar

Joined: Tue Oct 09, 2007 2:15 am
Posts: 1084
Its since PB5 on my system. (5.00-5.20b10)

Code:
;{ here some code
Macro Lala(x)
  ; Nothing
EndMacro
;}


(In Preferences set Macro and EndMacro to folding Words....)

Mark the macro block between the comments and delete it wtih backspace.... you will see very strange folding issues...
on both IDE x86 and x64 (Windows)

_________________
PureBasic 5.71 LTS (Windows x86/x64) | Windows10 Pro x64 | Z370 Extreme4 | i7 8770k | 32GB RAM | iChill GeForce GTX 980 X4 Ultra | HAF XF Evo​​
English is not my native language... (I often use DeepL to translate my texts.)


Top
 Profile  
Reply with quote  
 Post subject: Re: PB5.1b4 - IDE folding indicator not updated
PostPosted: Fri Aug 16, 2013 5:34 am 
Offline
Addict
Addict
User avatar

Joined: Sat Feb 13, 2010 3:45 pm
Posts: 907
Fred wrote:
Does it still happen? Could you post the steps to repoduce it ?

Can confirm, the problem still exist (Pb 5.20b8). Sorry, can't give any example to reproduce the problem, I can't see any system.

I can't confirm the problem with Bisonte's code, it seems to me, the problem occur only with longer codes. I use only single folding steps (no folding inside folding).

At time, the once way to correct the problem is to copy all the code, delete all and paste the code again in the IDE.

josh

_________________
sorry for my bad english


Top
 Profile  
Reply with quote  
 Post subject: Re: PB5.1b4 - IDE folding indicator not updated
PostPosted: Fri Aug 16, 2013 9:23 am 
Offline
Addict
Addict

Joined: Thu Nov 01, 2007 5:37 pm
Posts: 1981
Location: Germany
The problem still exists using PB5.20b10.

Code to reproduce it:
Code:
Macro Test()
EndMacro
- Place the cursor in the middle of "EndMacro", press enter, then backspace. Now the last indicator (line 2) should look opened like there is something coming after it. Triggering the folding update routine by creating a new line somewhere else fixes it.

Another one:
Code:
;{
Procedure Test1()
EndProcedure

Procedure Test2()
EndProcedure
;}
- Select "Test1()" (including Procedure and EndProcedure) and delete it.
- Make sure that the last line is empty, so 8 in total. Now select everything (from ;{ to ;}) and delete it.

_________________
If any of you native English speakers have any suggestions for the above text, please let me know (via PM). Thanks!


Top
 Profile  
Reply with quote  
 Post subject: Re: PB5.1b4 - IDE folding indicator not updated
PostPosted: Fri Aug 16, 2013 10:33 am 
Offline
Enthusiast
Enthusiast

Joined: Wed Feb 01, 2012 5:30 pm
Posts: 199
Location: Russian Federation
Confirmed

_________________
Former user of pirated PB.
Now registered user :].


Top
 Profile  
Reply with quote  
 Post subject: Re: PB5.1b4 - IDE folding indicator not updated
PostPosted: Tue Nov 12, 2013 1:45 am 
Offline
PureBasic Team
PureBasic Team
User avatar

Joined: Fri Apr 25, 2003 5:21 pm
Posts: 5781
Location: Germany
All fixed except the following one. Dunno yet what causes this.

c4s wrote:
Code to reproduce it:
Code:
Macro Test()
EndMacro
- Place the cursor in the middle of "EndMacro", press enter, then backspace. Now the last indicator (line 2) should look opened like there is something coming after it. Triggering the folding update routine by creating a new line somewhere else fixes it.

_________________
quidquid Latine dictum sit altum videtur


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye