PureBasic Forum
https://www.purebasic.fr/english/

Please change requirements for MacOS version
https://www.purebasic.fr/english/viewtopic.php?f=37&t=71671
Page 1 of 1

Author:  Shardik [ Sun Nov 04, 2018 9:05 pm ]
Post subject:  Please change requirements for MacOS version

The PureBasic website states as requirement for the MacOS version:
Requirements

- MacOS X 10.5+ (Leopard or above)

Unfortunately this is no longer true. On MacOS 10.6.8 'Snow Leopard' using PB 5.46 and PB 5.62 only the compilation with the 32-bit compiler is possible. The last PB version on Snow Leopard working with the 64-bit compiler was 5.43.

In PB 5.70 Beta 2 both the 32-bit and 64-bit compiler don't work anymore on MacOS 10.6.8 'Snow Leopard' and MacOS 10.7.5 'Lion'. This error message is shown for PB 5.70 Beta 2 on Lion (translated to English: Wrong compiler feedback. Possibly not the correct compiler version. Please reinstall PureBasic.):
Image
The oldest MacOS version with PB 5.70 Beta 2 working on (both 32-bit and 64-bit compilers) is MacOS 10.8.5 'Mountain Lion'. Therefore the requirements on PureBasic's website should be adapted.

Author:  deeproot [ Mon Dec 17, 2018 12:42 pm ]
Post subject:  Re: Please change requirements for MacOS version

Just got around to trying this myself. Shardik is of course correct.

Using PureBasic 5.70 Beta 4 x86 - refuses to run on my elderly iMac with Snow Leopard 32-bit.

Part of the problem report is as follows:
Quote:
Process: PureBasic [184]
Path: /Users/geoff/PureBasic-5.70b4.app/Contents/MacOS/PureBasic
Identifier: com.fantaisiesoftware.purebasicide
Version: ??? (0.1)
Code Type: X86 (Native)
Parent Process: launchd [92]

Date/Time: 2018-12-17 09:44:27.719 +0000
OS Version: Mac OS X 10.6.8 (10K549)
Report Version: 6

Interval Since Last Report: 2529172 sec
Crashes Since Last Report: 17
Per-App Interval Since Last Report: 1888449 sec
Per-App Crashes Since Last Report: 1
Anonymous UUID: BCB57E0E-983E-406B-9812-2B01025F6F1B

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Symbol not found: _kSecImportExportPassphrase
Referenced from: /Users/geoff/PureBasic-5.70b4.app/Contents/MacOS/PureBasic
Expected in: /System/Library/Frameworks/Security.framework/Versions/A/Security
in /Users/geoff/PureBasic-5.70b4.app/Contents/MacOS/PureBasic

In the Help file with PB 5.70b4 the requirement page also says "MacOS X (10.6 or above)" so like website this wrongly implies it should work.

If it is the team's intention to no longer support the older versions of MacOS then I can fully respect that.

However, for me it's a great shame as I only have one Mac system - old and not much memory, bought with Snow Leopard 32-bit installed and I've no intention of changing it! Yes, I know it's not supported and so on, but it runs fast, is reliable and a pleasure to work on. PureBasic 5.62 runs perfectly and I can continue with it. The machine is only used for PureBasic and related work, not much else and internet access only rarely and with care.

I have several customers who are still using Snow Leopard. Without an additional later Mac system, I cannot verify if programs compiled with 5.70 will still execute on 10.6 or 10.7.

Author:  Mesa [ Sat Dec 22, 2018 11:12 am ]
Post subject:  Re: Please change requirements for MacOS version

Fixed in the help file but not in the site because only Fred can make the change.
However, I'm going to ask Fred more about this.

Author:  Andre [ Sat Dec 22, 2018 11:59 pm ]
Post subject:  Re: Please change requirements for MacOS version

Just a note: the x86 version of PB5.70 beta runs fine on my MacBook with OSX 10.6.8 - so probably there must be different notes regarding x86 and x64 versions of PB...

Author:  mk-soft [ Sun Dec 23, 2018 12:42 pm ]
Post subject:  Re: Please change requirements for MacOS version

Andre wrote:
Just a note: the x86 version of PB5.70 beta runs fine on my MacBook with OSX 10.6.8 - so probably there must be different notes regarding x86 and x64 versions of PB...

Which Xcode version do you use?

Author:  Andre [ Fri Dec 28, 2018 12:35 am ]
Post subject:  Re: Please change requirements for MacOS version

mk-soft wrote:
Andre wrote:
Just a note: the x86 version of PB5.70 beta runs fine on my MacBook with OSX 10.6.8 - so probably there must be different notes regarding x86 and x64 versions of PB...

Which Xcode version do you use?


Sorry for the confusion... :oops: I just wasn't aware, that I was still using PB5.62 (x86) on my OSX 10.6.8 MacBook, when testing my GeoWorld project for compatibility with MacOS (while main developing is done on a high-end Win10 laptop).

So I still need to download/try PB5.70 beta on MacOS. But I assume, that you're right with the reported problems... :?

Author:  Andre [ Fri Jan 11, 2019 10:04 pm ]
Post subject:  Re: Please change requirements for MacOS version

Just to be complete / up-to-date:

I'm using MacOS El Capitan (10.11) on my MacBook (couldn't upgrade to a newer version, as the "Apple Hardware Check" says that my system of 2011 is too old....
Probably the oldest MacOS version; which works correctly with new PB5.70?

Author:  Shardik [ Sat Jan 12, 2019 10:12 am ]
Post subject:  Re: Please change requirements for MacOS version

Andre wrote:
Probably the oldest MacOS version; which works correctly with new PB5.70?
Shardik wrote:
The oldest MacOS version with PB 5.70 Beta 2 working on (both 32-bit and 64-bit compilers) is MacOS 10.8.5 'Mountain Lion'.

I have now again tested PB 5.70 final with
- MacOS 10.6.8 (Snow Leopard)
- MacOS 10.7.5 (Lion)
- MacOS 10.8.6 (Mountain Lion)
My finding about Mountain Lion being the minimum version required to start the PureBasic IDE still holds true for PB 5.70 final.

This is the crash report on Lion when trying to start PB 5.70 x86 (only top lines):
Quote:
Process: PureBasic [366]
Path: /Volumes/VOLUME/Applications/PureBASIC/*/PureBASIC 5.70 x86.app/Contents/MacOS/PureBasic
Identifier: com.fantaisiesoftware.purebasicide
Version: ??? (0.1)
Code Type: X86 (Native)
Parent Process: launchd [240]

Date/Time: 2019-01-12 09:42:46.349 +0100
OS Version: Mac OS X 10.7.5 (11G63)
Report Version: 9

Interval Since Last Report: 13541 sec
Crashes Since Last Report: 15
Per-App Interval Since Last Report: 10664 sec
Per-App Crashes Since Last Report: 1
Anonymous UUID: BD92EFD8-0709-4032-97AC-0E3C5445B23C

Crashed Thread: 8

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: 0x000000000000000d, 0x0000000000000000

VM Regions Near 0:
--> __PAGEZERO 0000000000000000-0000000000001000 [ 4K] ---/--- SM=NUL /Volumes/VOLUME/Applications/PureBASIC/*/PureBASIC 5.70 x86.app/Contents/MacOS/PureBasic
__TEXT 0000000000001000-00000000004aa000 [ 4772K] r-x/rwx SM=COW /Volumes/VOLUME/Applications/PureBASIC/*/PureBASIC 5.70 x86.app/Contents/MacOS/PureBasic

Application Specific Information:
objc[366]: garbage collection is OFF

Dyld Error Message:
Symbol not found: _SSLCreateContext
Referenced from: /Volumes/VOLUME/Applications/PureBASIC/*/PureBASIC 5.70 x86.app/Contents/MacOS/PureBasic
Expected in: /System/Library/Frameworks/Security.framework/Versions/A/Security


This is the crash report on Snow Leopard when trying to start PB 5.70 x64 (only top lines):
Quote:
Process: PureBasic [325]
Path: /Applications/PureBASIC/5.70 x64/PureBASIC 5.70 x64.app/Contents/MacOS/PureBasic
Identifier: com.fantaisiesoftware.purebasicide
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: launchd [264]

Date/Time: 2019-01-12 09:54:46.260 +0100
OS Version: Mac OS X 10.6.8 (10K549)
Report Version: 6

Interval Since Last Report: 15921768 sec
Crashes Since Last Report: 300
Per-App Crashes Since Last Report: 8
Anonymous UUID: 5A8D2C9A-66DB-4394-BD12-1ED53AB97812

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /usr/lib/libc++.1.dylib
Referenced from: /Applications/PureBASIC/5.70 x64/PureBASIC 5.70 x64.app/Contents/MacOS/PureBasic
Reason: image not found

Binary Images:
0x7fff5fc00000 - 0x7fff5fc3bdef dyld 132.1 (???) <472D950D-70F8-B810-A959-9184C2AA6C74> /usr/lib/dyld

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/