PureBasic Forum
https://www.purebasic.fr/english/

Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS
https://www.purebasic.fr/english/viewtopic.php?f=26&t=61444
Page 3 of 4

Author:  linkerstorm [ Wed Jan 27, 2016 7:46 am ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

Hi mpz.

Great job.

However, the link http://www.flasharts.de/mpz/Tailbite/Tailbite.exe leads to a Not Found page.

Could you advice please ?

Thanks.

Author:  RSBasic [ Wed Jan 27, 2016 12:24 pm ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

http://www.rsbasic.de/backups/ :arrow: http://www.rsbasic.de/backupprogramme/Tailbite.exe

Author:  linkerstorm [ Thu Jan 28, 2016 7:35 am ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

Thanks RSBasic.

However, comparing your exe with my 1.4.16 exe, they are strictly identical so I deduce that this is in fact the 1.4.16 version, or my version is finally the 1.4.17 version (how to know ?).

Maybe have you the version 1.4.17 backed up somewhere ?

Thanks in advance.

Author:  RSBasic [ Thu Jan 28, 2016 4:02 pm ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

I'm sorry, it's the version 1.4.16. I don't have 1.4.17. :(

Author:  Sveinung [ Fri Jan 29, 2016 12:33 pm ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

http://www.sherrox.com/Tailbite.exe

Regards
Sveinung

Author:  mpz [ Fri Jan 29, 2016 11:32 pm ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

Hi,

thanks Sveinung for the link. I am sorry, it was my fault. I have the link checked and repaired:

The exe file for exchange, version 1.4.17
http://www.flasharts.de/mpz/Tailbite/Tailbite.exe


Greetings
Michael

Author:  linkerstorm [ Sat Jan 30, 2016 7:52 am ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

Hi.

Thanks to Sveinung and mpz for the link :D

Regards

Author:  User_Russian [ Fri Mar 04, 2016 9:42 pm ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

Where Tailbite it creates temporary files? When building the library, FASM reports an error in the ASM file, but where these files?

Author:  mpz [ Mon Mar 14, 2016 1:16 am ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

Hi User_Russian.

i am sorry, i dont saw your question. In the Tailbite manager you fins the information about the "ASM Souce file folder". If you choose the function "generate build batch file" you have in the folder a batch file for asm generation.

You can send the exactly asm error message and perhaps i know the error

P.S: or you send me with pm the files and i can test them an tell you the problem...

Greetings
Michael

Author:  Rings [ Mon Mar 14, 2016 8:52 am ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

any chance to get the source of actual tailbite instead of the exe ?

Author:  User_Russian [ Mon Mar 14, 2016 6:08 pm ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

mpz wrote:
You can send the exactly asm error message and perhaps i know the error
Quote:
TailBite Error

FAsm: Shared\G_ZIP_UnPack.asm
Error
Line no: 76
Error code: -122
Error String: UNDEFINED_SYMBOL

Author:  User_Russian [ Mon Mar 14, 2016 6:35 pm ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

Here is the code which compiles fine in PB, but not compiled in TailBite.
Code:
Procedure DataS()
  Protected x
 
  x=?m1
 
  ProcedureReturn
  DataSection
    m1:
    Data.i 0
  EndDataSection
EndProcedure

ProcedureDLL x()
  DataS()
EndProcedure

Code:
DeclareModule xx
Declare DataS()
EndDeclareModule

Module xx
Procedure DataS()
  Protected x
 
  ProcedureReturn
EndProcedure
EndModule

DeclareModule yy
Declare DataS()
EndDeclareModule

Module yy
Procedure DataS()
  Protected x
   
  ProcedureReturn
EndProcedure
EndModule

ProcedureDLL x()
  xx::DataS()
  yy::DataS()
EndProcedure

Author:  acreis [ Mon Mar 14, 2016 6:46 pm ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

I think Tailbite can't work properly with Modules.

Author:  mpz [ Wed Mar 16, 2016 10:24 pm ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

Hi,

@Rings -> you find the sourcecode in the first posting as files

@User_Russian -> Error String: UNDEFINED_SYMBOL. I think a adress label is wrong.

show me the txt of the line 76 in the asm code
Shared\G_ZIP_UnPack.asm

The adesslabel is not definied. If you can send me the code i can look on it an repair tailbite. Without the code i cant help.

Problem
"Here is the code which compiles fine in PB, but not compiled in TailBite."

i have tested both code with PB5.31 x86 and PB5.42 x86 an they work. Modules are not a problem. I can create a working lib without problems ?!?

Perhaps you dont use an older version of tailbite and not the tailbite 1.4.17. With an older version you have adresslabel problems...

Greetings Michael

Author:  User_Russian [ Thu Mar 17, 2016 10:05 am ]
Post subject:  Re: Tailbite v1.4.17 for Windows and PB 5.31 + PB 5.40 LTS

Quote:
show me the txt of the line 76 in the asm code
I can not find assembler files. The folder "TailBite Library Sources" no files.

Quote:
Perhaps you dont use an older version of tailbite and not the tailbite 1.4.17.
I downloaded here viewtopic.php?p=480999#p480999
In TBManager in FrameGadget written "Tailbite 1.4.11 console".

Quote:
I can create a working lib without problems
Is it possible to have an output lib-file (static library), and not PB library?

Page 3 of 4 All times are UTC + 1 hour
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/