It is currently Fri Jan 15, 2021 3:44 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 62 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next
Author Message
 Post subject: Re: Gnozal tools updater
PostPosted: Fri Apr 09, 2010 2:12 pm 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Update

Changes :
- updated for PB4.50

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject: Re: Gnozal tools updater
PostPosted: Mon May 17, 2010 12:54 pm 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Update

Changes :
- new host : gnozal.ucoz.com

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject: POLINK error
PostPosted: Sat May 22, 2010 11:14 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Jan 29, 2010 1:05 pm
Posts: 221
Location: Brazil
Hi gnozal!

I'm using PB 4.5b4
I downloaded your Library Updater and checked '4.5x', downloaded and installed all the libs, but almost every example i try gives me this

"POLINK: error: Unresolved external symbol '_PB_StringBasePosition'.
POLINK: fatal error: 1 unresolved external(s)."

Have I done anything wrong?


Last edited by PureLeo on Mon May 24, 2010 3:13 pm, edited 2 times in total.

Top
 Profile  
Reply with quote  
 Post subject: Re: POLINK error
PostPosted: Sun May 23, 2010 4:41 am 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Jan 29, 2010 1:05 pm
Posts: 221
Location: Brazil
Hm, nevermind.....

I just reinstalled my PB 4.5 and now it works fine... hate computers.

Sorry ;D


Top
 Profile  
Reply with quote  
 Post subject: Re: POLINK error
PostPosted: Mon May 24, 2010 3:18 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Jan 29, 2010 1:05 pm
Posts: 221
Location: Brazil
Oops, sorry but i was wrong...

Some of them work like PureDIC, PureRESIZE, PureAES, PureLZMA,
and some still give that error, like PurePOP3, PurePROC, PureVALID, PureSMTP...


Top
 Profile  
Reply with quote  
 Post subject: Re: POLINK error
PostPosted: Mon May 24, 2010 3:42 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Jan 29, 2010 1:05 pm
Posts: 221
Location: Brazil
Hi again.. I was messing around with everything and just found out that the libs work well when I disable the "Thread Safe" option in the compiler options :)


Top
 Profile  
Reply with quote  
 Post subject: Re: Gnozal tools updater
PostPosted: Fri May 27, 2011 7:18 pm 
Offline
Addict
Addict
User avatar

Joined: Wed Apr 30, 2003 8:15 am
Posts: 1067
Location: Germany
The latest Gtu v1.15 have some bugs with the new PB4.6 features.
The IDE path cannot set. It overides the PB4.5 path.
Checkbox state for UserLibs (PB4.6) will not saved.
Unchecking all PB Version except 4.6 will disable all checkboxes...
Seems like checking v4.6 libs is not possible...

Ciao dige

_________________
"Daddy, I'll run faster, then it is not so far..."


Top
 Profile  
Reply with quote  
 Post subject: Re: Gnozal tools updater
PostPosted: Sat May 28, 2011 9:06 am 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
dige wrote:
The latest Gtu v1.15 have some bugs with the new PB4.6 features.
The IDE path cannot set. It overides the PB4.5 path.
Should be fixed.
dige wrote:
Checkbox state for UserLibs (PB4.6) will not saved.
Should be fixed.
dige wrote:
Unchecking all PB Version except 4.6 will disable all checkboxes...
Should be fixed.
dige wrote:
Seems like checking v4.6 libs is not possible...
It is, but none is available yet.

New build uploaded.

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject: Re: Gnozal tools updater
PostPosted: Wed Dec 14, 2011 8:18 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jun 09, 2003 8:30 am
Posts: 196
Installing for pb 4.60 with th eLibraryUpdater install all but the residents ..

manuall install (calling PureLPRINT-460-Installer.exe manually)
install correct and complete.

-----------

Part 2

Installing for Pb 4.50 via LibraryUpdater has the same effect

_________________
사십 둘 .


Top
 Profile  
Reply with quote  
 Post subject: Re: Gnozal tools updater
PostPosted: Thu Dec 15, 2011 9:41 am 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Update

Changes :
- added ''RES5'' signature for resident files : this should fix the PB4.5x/PB4.6x resident installation issue.

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject: Re: Gnozal tools updater
PostPosted: Fri Dec 16, 2011 5:59 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jun 09, 2003 8:30 am
Posts: 196
it DOES fix it Image

_________________
사십 둘 .


Top
 Profile  
Reply with quote  
 Post subject: Re: Gnozal tools updater
PostPosted: Wed Aug 15, 2012 8:09 am 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Update

Changes :
- check if download directory is valid before starting download

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject: Re: Gnozal tools updater
PostPosted: Mon Oct 01, 2012 8:22 am 
Offline
Addict
Addict
User avatar

Joined: Tue Jul 22, 2003 5:02 pm
Posts: 1542
Location: In a long distant galaxy
Hi Gnozal,

Are your libs availables for x64 ?

I need to compile a project in 64 bits using these libs : PureResize, PureLVSort.

If i try to install x86 libs on a x64 Purebasic,
it leads to this message 'POLINK: Fatal Error: Corrupt library: .\PureRESIZE_LIB_6.lib'

_________________
No programming language is perfect. There is not even a single best language.
There are only languages well suited or perhaps poorly suited for particular purposes. Herbert Mayer


Top
 Profile  
Reply with quote  
 Post subject: Re: Gnozal tools updater
PostPosted: Tue Oct 02, 2012 11:25 am 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Flype wrote:
Are your libs availables for x64 ?
Hi Flype,
no, only x86.

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject: Re: Gnozal tools updater
PostPosted: Sun Oct 07, 2012 8:03 pm 
Offline
Addict
Addict
User avatar

Joined: Tue Jul 22, 2003 5:02 pm
Posts: 1542
Location: In a long distant galaxy
Ok no problem.

I managed to remove all pureresize and purecolor by replacing them with purebasic set.

Thanks

_________________
No programming language is perfect. There is not even a single best language.
There are only languages well suited or perhaps poorly suited for particular purposes. Herbert Mayer


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 62 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye