It is currently Mon Oct 14, 2019 4:24 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 1542 posts ]  Go to page Previous  1 ... 98, 99, 100, 101, 102, 103  Next
Author Message
 Post subject: Re: jaPBe 3.12.8 [IDE for PB 4.xx]
PostPosted: Sat Oct 20, 2012 2:44 pm 
Offline
New User
New User

Joined: Fri Oct 19, 2012 3:27 pm
Posts: 3
gnozal wrote:
user3162 wrote:
When I try install or use this under Win7 Home Premium, I get this:
Error:'C:\Program Files\PureBasic\Compilers\pbcompiler.exe' is not a x86 executable!
The path is correct.
Do you installed the PB x86 version (32 bit) or the 64 bit version ?
jaPBe only supports PB x86.


64, that would be it, then, thanks!


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.8 [IDE for PB 4.xx]
PostPosted: Wed Dec 12, 2012 11:24 am 
Offline
Enthusiast
Enthusiast

Joined: Sun Apr 06, 2008 12:54 pm
Posts: 374
Location: Brisbane, Qld, Australia
My 'find in files' window is often displayed part-way off the bottom of the screen, and today it disappeared altogether - even after closing and restarting jaPBe. I then had a look at jaPBe.pref and found that FindInFileY is actually being saved as FindInFileX, ie FindInFileX is twice in the file and FindInFileY doesn't exist at all. To reinstate the 'find in files' window I deleted the 4 FindInFile... entries.

(Using jaPBe 3.12.8.873)

_________________
Mike
www.showcuesystems.com


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.8 [IDE for PB 4.xx]
PostPosted: Wed Dec 12, 2012 2:28 pm 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
ozzie wrote:
My 'find in files' window is often displayed part-way off the bottom of the screen, and today it disappeared altogether - even after closing and restarting jaPBe. I then had a look at jaPBe.pref and found that FindInFileY is actually being saved as FindInFileX, ie FindInFileX is twice in the file and FindInFileY doesn't exist at all. To reinstate the 'find in files' window I deleted the 4 FindInFile... entries.
(Using jaPBe 3.12.8.873)
Should be fixed in build 878.

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.8 [IDE for PB 4.xx]
PostPosted: Thu Dec 13, 2012 11:02 am 
Offline
Enthusiast
Enthusiast

Joined: Sun Apr 06, 2008 12:54 pm
Posts: 374
Location: Brisbane, Qld, Australia
gnozal wrote:
ozzie wrote:
My 'find in files' window is often displayed part-way off the bottom of the screen, and today it disappeared altogether - even after closing and restarting jaPBe. I then had a look at jaPBe.pref and found that FindInFileY is actually being saved as FindInFileX, ie FindInFileX is twice in the file and FindInFileY doesn't exist at all. To reinstate the 'find in files' window I deleted the 4 FindInFile... entries.
(Using jaPBe 3.12.8.873)
Should be fixed in build 878.

Thanks, gnozal. Working fine now.

_________________
Mike
www.showcuesystems.com


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.12 [IDE for PB 4 and PB 5]
PostPosted: Fri Feb 15, 2013 2:49 pm 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Update

Changes :
 - added PB5.10 'check syntax only' feature (see 'Project menu')

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.12 [IDE for PB 4 and PB 5]
PostPosted: Mon Apr 15, 2013 12:23 am 
Offline
Enthusiast
Enthusiast

Joined: Sun Apr 06, 2008 12:54 pm
Posts: 374
Location: Brisbane, Qld, Australia
I have a .pbi include file in my project that contains text in Japanese in a Data section. The original text was translated for me and supplied in a file which I then copied into the relevant part of the include file. But when I viewed the file in jaPBe I just got question marks for the Japanese characters. On searching the Forum I found Trond's solution of setting the File Format to UTF8, but I couldn't find an option to do this in jaPBe so had to set the file format using the PB IDE. The file now views correctly in jaPBe, but is there a way I could have set the file format in jaPBe? (I'm using jaPBe 3.12.12.878.)

_________________
Mike
www.showcuesystems.com


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.12 [IDE for PB 4 and PB 5]
PostPosted: Mon Apr 15, 2013 2:56 am 
Offline
Addict
Addict
User avatar

Joined: Mon Jul 25, 2005 3:51 pm
Posts: 3584
Location: Utah, USA
ozzie wrote:
I have a .pbi include file in my project that contains text in Japanese in a Data section. The original text was translated for me and supplied in a file which I then copied into the relevant part of the include file. But when I viewed the file in jaPBe I just got question marks for the Japanese characters. On searching the Forum I found Trond's solution of setting the File Format to UTF8, but I couldn't find an option to do this in jaPBe so had to set the file format using the PB IDE. The file now views correctly in jaPBe, but is there a way I could have set the file format in jaPBe? (I'm using jaPBe 3.12.12.878.)


It's under the Project Menu -- Project Options -- General Tab -- Code Page comboBox.

_________________
Image


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.12 [IDE for PB 4 and PB 5]
PostPosted: Mon Apr 15, 2013 8:01 am 
Offline
Addict
Addict
User avatar

Joined: Tue Oct 09, 2007 2:15 am
Posts: 1084
a strange error occured. If I try to load the jaPBe.pb (source of it) this happens :
* image removed *
and japbe quit.

But its a "userlib and own resident free" pb installation.
PB5.11 x86, win7x64, jaPBe Build: 879

and JaPBe crashes if I try to open the "About" Window...
(in XP compat. Mode : I see the window and the images but no text and crash)

_________________
PureBasic 5.71 LTS (Windows x86/x64) | Windows10 Pro x64 | Z370 Extreme4 | i7 8770k | 32GB RAM | iChill GeForce GTX 980 X4 Ultra | HAF XF Evo​​
English is not my native language... (I often use DeepL to translate my texts.)


Last edited by Bisonte on Wed May 15, 2013 7:37 pm, edited 1 time in total.

Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.12 [IDE for PB 4 and PB 5]
PostPosted: Mon Apr 15, 2013 8:16 am 
Offline
Addict
Addict
User avatar

Joined: Mon Jul 25, 2005 3:51 pm
Posts: 3584
Location: Utah, USA
Bisonte wrote:
a strange error occured. If I try to load the jaPBe.pb (source of it) this happens :

and japbe quit.


I've had this happen recently too. It happens when using the most recent build of jaPBe (and the previous ones also) and the PureBasic compiler for v5.11 (and also v5.10). I had to edit the preference file to reset the compiler to something older for it to work again. I can't use the most recent compiler with the sources I am editing because of this. In my case I think it relates to jaPBe pre-checking imports in my sources but I can't be sure. :cry:

_________________
Image


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.12 [IDE for PB 4 and PB 5]
PostPosted: Mon Apr 15, 2013 3:57 pm 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Unfortunately, I can't reproduce these crashes. (PB 5.11 WinXP x86).

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.12 [IDE for PB 4 and PB 5]
PostPosted: Tue Apr 16, 2013 2:44 am 
Offline
Addict
Addict
User avatar

Joined: Mon Jul 25, 2005 3:51 pm
Posts: 3584
Location: Utah, USA
gnozal wrote:
Unfortunately, I can't reproduce these crashes. (PB 5.11 WinXP x86).


Gnozal,

The error that Bisnote and I both reported is triggered for me when I load the source code file for jaPBe called 'jaPBe.bp'. The portion causing the error is at the end (and contains jaPBe settings) and will cause jaPBe to terminate even if it is the only thing in the file. This code only will cause an error (and termination) if the compiler is also set to v5.10 or later. Maybe your expert eyes can narrow it down further.

Code:
; jaPBe Version=3.12.8.873
; ResourceType3=20
; ResourceName=compiling
; ResourceLanguage=0
; ResourceFile=Compiling.avi
; ResourceType3=9
; ResourceName=2
; ResourceLanguage=0
; ResourceFile=CombinedInclude.ico
; Build=883
; Working Directory=C:\Purebasic394\Compilers\
; ProductName=The new jaPBe V3 for PB4.xx
; ProductVersion=3.%year0%.%month%.%build%
; CompanyName=Feel the Pure Power !
; FileDescription=just another PureBasic editor
; FileVersion=3.%year0%.%month%.%build%
; InternalName=jaPBe
; LegalCopyright=gnozal (a.k.a. Philippe GUNTZ)
; OriginalFilename=%exe%
; Comments=Supports PB4.0x to PB4.6x
; Language=0x0000 Language Neutral
; FirstLine=0
; CursorPosition=0
; EnableNT4
; EnableXP
; EnableOnError
; UseIcon=jaPBeEXE.ico
; ExecutableFormat=Windows
; Executable=jaPBe.exe
; SaveDeclare
; EOF

_________________
Image


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.12 [IDE for PB 4 and PB 5]
PostPosted: Tue Apr 16, 2013 8:16 am 
Offline
Addict
Addict
User avatar

Joined: Tue Oct 09, 2007 2:15 am
Posts: 1084
Wow...

If I delete these rows with another text-editor, no crash....

_________________
PureBasic 5.71 LTS (Windows x86/x64) | Windows10 Pro x64 | Z370 Extreme4 | i7 8770k | 32GB RAM | iChill GeForce GTX 980 X4 Ultra | HAF XF Evo​​
English is not my native language... (I often use DeepL to translate my texts.)


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.12.12 [IDE for PB 4 and PB 5]
PostPosted: Tue Apr 16, 2013 10:53 am 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Demivec wrote:
gnozal wrote:
Unfortunately, I can't reproduce these crashes. (PB 5.11 WinXP x86).

Gnozal,
The error that Bisnote and I both reported is triggered for me when I load the source code file for jaPBe called 'jaPBe.bp'. The portion causing the error is at the end (and contains jaPBe settings) and will cause jaPBe to terminate even if it is the only thing in the file. This code only will cause an error (and termination) if the compiler is also set to v5.10 or later. Maybe your expert eyes can narrow it down further...

I think I found the problem : the NT4 subsystem is missing in PB5.1x...
Create an empty 'NT4' directory in 'SubSystems' and no more crash.

New jaPBe build (880) uploaded.

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject: Using jaPB and PureFORM together
PostPosted: Tue Jun 25, 2013 8:51 am 
Offline
Enthusiast
Enthusiast

Joined: Wed Feb 29, 2012 8:04 am
Posts: 190
Location: Melbourne, AUS
Hi gnozal,

I'm sorry to ask this question, as I have seen that you have answered similar questions before, but I am still not 100% clear on how to use jaPB and PF together.

I have PF as a plugin to jaPB and I want to start a new project "MyProject".

Do I create the new project in jaPB which creates the files:
MyProject.pb
MyProject.pbfl

or do I call up PF straight away from jaPB and then let PF create MyProject.pb

I think what is confusing me is:

Is MyProject.pb the "main.pb" file, which in this case includes the window definitions ?

I usually have the window definitions in a separate file, which is then "Included" in the main.pb file.

Thanks,

Neil


Top
 Profile  
Reply with quote  
 Post subject: Re: jaPBe 3.13.4 [IDE for PB 4 and PB 5]
PostPosted: Sun Jun 30, 2013 11:45 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Wed Jun 28, 2006 6:55 pm
Posts: 146
Location: Schröttersburg
Is there a chance for stop using the PEComp?

_________________
Image


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1542 posts ]  Go to page Previous  1 ... 98, 99, 100, 101, 102, 103  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye