It is currently Thu May 28, 2020 2:00 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 1545 posts ]  Go to page Previous  1 ... 5, 6, 7, 8, 9, 10, 11 ... 103  Next
Author Message
 Post subject:
PostPosted: Wed Feb 22, 2006 10:09 am 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Update

Changes :
- some fixes
- added /SUBSYSTEM OPENGL compiler flag

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Wed Feb 22, 2006 11:23 am 
Offline
Addict
Addict
User avatar

Joined: Tue Jul 22, 2003 5:02 pm
Posts: 1542
Location: In a long distant galaxy
Hello Gnozal,

Considering the number of updates you made to jaPBe,
In my humble opinion, i think it's time, if you can, to add a 'UniversalInternetUpdate' profile in the 'C:\Program files\jaPBe\uiu\' folder.

For example, the 'japbebeta.txt' file :
Code:
Info = jaPBe Beta Release
URL = http://gpihome.de/uiu/japbe/beta
Install = *
SimpleCharConvert = 1


You might create yours in order to allow us to update easily your 'hotfixes'. :wink:
It could be 'japbepb4.txt' :
Code:
Info = jaPBe PB4.0 Release
URL = http://people.freenet.de/gnozal/
Install = *
SimpleCharConvert = 1

_________________
No programming language is perfect. There is not even a single best language.
There are only languages well suited or perhaps poorly suited for particular purposes. Herbert Mayer


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Wed Feb 22, 2006 11:44 am 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Flype wrote:
Hello Gnozal,
Considering the number of updates you made to jaPBe,
In my humble opinion, i think it's time, if you can, to add a 'UniversalInternetUpdate' profile in the 'C:\Program files\jaPBe\uiu\' folder.
Don't worry, it should be the last update before PB4.00 final (except bug fixes).
When PB4.00 final is released, I will update HELP.PBI (I cannot do this now as I don't know the structure of the new Purebasic.chm).
Concerning the automatic update, I don't know how it works, have never used it (firewall ...) and it means uploading all files separately (and not in one archive) wich is non very convenient for me as I cannot use FTP (firewall ... again ...). Sorry.

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Wed Feb 22, 2006 12:07 pm 
Offline
Addict
Addict
User avatar

Joined: Tue Jul 22, 2003 5:02 pm
Posts: 1542
Location: In a long distant galaxy
Tant pis :D

_________________
No programming language is perfect. There is not even a single best language.
There are only languages well suited or perhaps poorly suited for particular purposes. Herbert Mayer


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Wed Feb 22, 2006 5:05 pm 
Offline
Addict
Addict
User avatar

Joined: Thu Jul 01, 2004 2:51 am
Posts: 898
Location: Tacoma, WA
gnozal - I still haven't had time to test my main program with the unicode switch but I have another problem that I'm seeing. I'm not even sure this is completely a japbe error.

It's weird but sometimes when I try to compile/debug japbe will act like it's compiling (all of the compile menu options become grayed out and the little compiling avi plays in the bottom-left portion) but then nothing. It just hangs there. I have to click "Restart Compiler" to get japbe working again. I can do compile without debug and compile executable fine. Just not debug. It's very strange and it's happened before. Has anyone else had this happened? What can I do?


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Thu Feb 23, 2006 1:16 am 
Offline
PureBatMan Forever
PureBatMan Forever
User avatar

Joined: Tue Feb 10, 2004 3:07 am
Posts: 2307
Location: Ohio, USA
I'm with you Xombie - same lock up when using compile/debug. :(

@GPI: Thank you for giving birth to jaPBe :)

@gnozal: Thank you for al your efforts to keeping jaPBe alive :)

_________________
What goes around comes around.

PB 5.21 LTS (x86) - Windows 8.1


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Thu Feb 23, 2006 9:02 am 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Sparkie wrote:
I'm with you Xombie - same lock up when using compile/debug. :(

Doesn't happen here :shock: (Win98SE or WinNT4)
It happens only with F6, and not with F5 ? The only thing that is different between F5 and F6 is the #PB_FLG_DEBUGGER compiler flag (see COMPILER.PBI / CompileRun() function) ....
I did not change anything in the CompileRun() function, except a check to restart the compiler with the correct switches (if /UNICODE or /SUBSYSTEM).

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Thu Feb 23, 2006 1:57 pm 
Offline
Addict
Addict
User avatar

Joined: Wed Aug 24, 2005 4:02 pm
Posts: 1262
Location: Germany
gnozal wrote:
Concerning the automatic update, I don't know how it works, have never used it (firewall ...) and it means uploading all files separately (and not in one archive) wich is non very convenient for me as I cannot use FTP (firewall ... again ...). Sorry.


I use it the internetupdater for my own program. It's very easy.
There is an program 'UpdateCreator.exe', which generates the two files (archive), which you must upload. That's all.

_________________
Translated with http://www.DeepL.com/Translator

Download of PureBasic - Modules
Download of PureBasic - Programs

[Windows 10 x64] [PB V5.7x]


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Thu Feb 23, 2006 3:16 pm 
Offline
PureBatMan Forever
PureBatMan Forever
User avatar

Joined: Tue Feb 10, 2004 3:07 am
Posts: 2307
Location: Ohio, USA
gnozal wrote:
It happens only with F6, and not with F5 ?
That is correct. I have just uninstalled/reinstalled jaPBe (ver 2.5.4.22), then your PB4 patch (ver 2.6.2.2116) and still no luck. :?

_________________
What goes around comes around.

PB 5.21 LTS (x86) - Windows 8.1


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Thu Feb 23, 2006 3:28 pm 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Sparkie wrote:
gnozal wrote:
It happens only with F6, and not with F5 ?
That is correct. I have just uninstalled/reinstalled jaPBe (ver 2.5.4.22), then your PB4 patch (ver 2.6.2.2116) and still no luck. :?
Hard to fix a bug if it can't reproduce it ...
Maybe it's because of the external debugger (the official PBIDE uses it's own internal debugger by default). Can you reproduce the problem with the official IDE + external debugger ?

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Thu Feb 23, 2006 3:51 pm 
Offline
PureBatMan Forever
PureBatMan Forever
User avatar

Joined: Tue Feb 10, 2004 3:07 am
Posts: 2307
Location: Ohio, USA
gnozal wrote:
Hard to fix a bug if it can't reproduce it ...
Been there a few times myself. ;)

No, I can't reproduce the bug with PB's integrated or standalone debugger.

I will experiment some more later tonight when I have more time. :)

_________________
What goes around comes around.

PB 5.21 LTS (x86) - Windows 8.1


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Thu Feb 23, 2006 4:00 pm 
Offline
PureBatMan Forever
PureBatMan Forever
User avatar

Joined: Tue Feb 10, 2004 3:07 am
Posts: 2307
Location: Ohio, USA
Solved the problem. It's a WinXP SP2 security issue.

Go to PureBasic\Compilers folder
Right click PBDebugger.exe and select Properties and then click Unblock
Right click PBDebuggerUnicode.exe and select Properties and then click Unblock

:D

_________________
What goes around comes around.

PB 5.21 LTS (x86) - Windows 8.1


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Thu Feb 23, 2006 4:07 pm 
Offline
PureBasic Expert
PureBasic Expert
User avatar

Joined: Sat Apr 26, 2003 8:27 am
Posts: 4229
Location: Strasbourg / France
Sparkie wrote:
Solved the problem. It's a WinXP SP2 security issue.
Glad to hear this :D But why only with jaPBe ?

_________________
For free libraries and tools, visit my web site (also home of jaPBe V3 and PureFORM).


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Thu Feb 23, 2006 4:35 pm 
Offline
PureBatMan Forever
PureBatMan Forever
User avatar

Joined: Tue Feb 10, 2004 3:07 am
Posts: 2307
Location: Ohio, USA
I just got to work and in addition to the 2 debugger exe's, I also had to Unblock PureBasic.exe in the Purebasic folder. Same goes for Visual Designer.exe.

gnozal wrote:
But why only with jaPBe ?
Attempting to execute app from a 3rd party app :?:

_________________
What goes around comes around.

PB 5.21 LTS (x86) - Windows 8.1


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Thu Feb 23, 2006 6:38 pm 
Offline
Enthusiast
Enthusiast

Joined: Tue Sep 30, 2003 4:32 pm
Posts: 196
Location: The Netherlands
GNozal,

Since YOU are the (un)offical code keeper of jaPBe can you add the HARD-CODED tabs instead of SPACES (sorry for shouting) or since everybode wants the spaces (i prefer TABS) to make it a switch?

That is the only thing wrong with jaPBe the rest is wonderfull!!

Oh one more thing is it possible to set all the fonts used with only ONE click of a button, now you have to do it one by one if one wants to switch fonts, from say corrier to fixedsys. Some kind of master button listbox?

Thanks for the conversion to PB4.

Jan Vooijs

_________________
Life goes to Fast, Enjoy!!

PB 4 is to good to be true, wake up man it is NOT a dream THIS is a reality!!!

AMD Athlon on 1.75G, 1Gb ram, 160Gb HD, NVidia FX5200, NEC ND-3500AG DVD+RW and CD+RW, in a Qbic EO3702A and Win XP Pro SP2 (registered)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1545 posts ]  Go to page Previous  1 ... 5, 6, 7, 8, 9, 10, 11 ... 103  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye