It is currently Wed Jul 08, 2020 11:22 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Problem with version 5.71
PostPosted: Wed Feb 26, 2020 8:41 am 
Offline
User
User

Joined: Fri Feb 15, 2019 11:16 am
Posts: 10
Location: France
Hi,
I downloaded PureBasic 5.71 LTS (MacOS X - x64) but when I launch it, I have the message "Cannot open PureBasic.app because Apple cannot verify that it does not contain malware. This software needs to be updated. Contact the developer for more information "
MacBookPro MacOS Catalina v. 10.15.3
Is it specific to my computer?
No problem with PB 5.70
j@cques

_________________
Sorry for my poor english
j@cques


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem with version 5.71
PostPosted: Wed Feb 26, 2020 9:25 am 
Offline
Enthusiast
Enthusiast

Joined: Wed Mar 11, 2009 4:06 pm
Posts: 284
Location: NL
Right click on PB app and select open. Tada.

Part of gatekeeper BS and Apple trying to get into control of what you may run on your mac and get statistics.

To get rid of these security messages, PB needs to be code signed and 'notarized' (which at the moment is an automatic process, but who knows what's next) by Apple and Apple only (no freedom of certificate choice) which at the very least needs a paid Apple dev account of 100 euro/year or something.

Applies to your own created applications too btw. Just instruct users to right click and choose open once. Next time it will not complain anymore.

Catalina is Apple's Vista (Permission/UAC mis-implementation dialogs everywhere)


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem with version 5.71
PostPosted: Wed Feb 26, 2020 9:45 am 
Offline
Administrator
Administrator

Joined: Fri May 17, 2002 4:39 pm
Posts: 14065
Location: France
PB app is signed, do i need to do an extra step now ?


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem with version 5.71
PostPosted: Wed Feb 26, 2020 10:12 am 
Offline
Enthusiast
Enthusiast

Joined: Wed Mar 11, 2009 4:06 pm
Posts: 284
Location: NL
Apparently notarization is now enforced (since feb 2020) afaik. Extra step and pita for Catarina. Kind of an automated malware check and entitlements stuff. A helpful howto is found here http://lessons.livecode.com/m/4071/l/11 ... c-appstore . Just ignore the livecode specifics.


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem with version 5.71
PostPosted: Wed Feb 26, 2020 10:56 am 
Offline
Administrator
Administrator

Joined: Fri May 17, 2002 4:39 pm
Posts: 14065
Location: France
As if it wasn't painful enough.. We will need 2 different DMG, one for pre 10.12 OS X and another for above.


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem with version 5.71
PostPosted: Wed Feb 26, 2020 11:02 am 
Offline
User
User

Joined: Fri Feb 15, 2019 11:16 am
Posts: 10
Location: France
Thank you all, for now I will be using version 5.70 which works perfectly.

_________________
Sorry for my poor english
j@cques


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye