It is currently Mon Dec 10, 2018 12:56 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: GetUserDirectory(Type) missing last '/'
PostPosted: Tue Mar 06, 2018 10:22 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 1473
Location: Germany
Only by MacOS missing last slash '/'
Code:
Debug GetUserDirectory(#PB_Directory_ProgramData)


Bugfix
Code:
CompilerIf #PB_Compiler_OS = #PB_OS_Windows
  #SEP$ = "\"
CompilerElse
  #SEP$ = "/"
CompilerEndIf

; Bugfix MacOS
CompilerIf #PB_Compiler_OS = #PB_OS_MacOS
  Procedure.s MyGetUserDirectory(Type)
    Protected r1.s
    r1 = GetUserDirectory(Type)
    If Right(r1, 1) <> #SEP$
      r1 + #SEP$
    EndIf
    ProcedureReturn r1
  EndProcedure
  Macro GetUserDirectory(Type)
    MyGetUserDirectory(Type)
  EndMacro
CompilerEndIf

_________________
My Projects OOP-BaseClass / OOP-BaseClassDispatch / Event-Designer /
PB v3.30 / v5.60 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye