It is currently Wed Nov 20, 2019 11:43 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Movie Library does not work on MacOS 10.15 Catalina
PostPosted: Tue Nov 05, 2019 12:09 am 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Tue Jan 31, 2006 9:43 am
Posts: 490
Location: France
Movie Library seems to be based on QuickTime 7 (32 bits), so it does not work anymore on MacOS 10.15 Catalina :?
(see viewtopic.php?f=19&t=59977&p=508493#p448989)

_________________
Niffo


Top
 Profile  
Reply with quote  
 Post subject: Re: Movie Library does not work on MacOS 10.15 Catalina
PostPosted: Fri Nov 08, 2019 7:02 pm 
Offline
PureBasic Expert
PureBasic Expert

Joined: Sun Aug 08, 2004 5:21 am
Posts: 3519
Location: Netherlands
The QuickTime framework was deprecated in OS X 10.9 but since macOS 10.15 it is no longer available.
That's why the Movie library is no longer working anymore.
It means that every PureBasic created app which uses the Movie library won't work properly on macOS 10.15 .
The only solution is that the Movie library would be rewritten using AVPlayer or AVQueuePlayer. There's no quick fix.

_________________
macOS 10.15 Catalina, PB 5.71 x64


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye