It is currently Tue Jan 21, 2020 11:37 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 15 posts ] 
Author Message
 Post subject: PB IDE Graphic problem
PostPosted: Tue Aug 13, 2019 10:26 pm 
Offline
Enthusiast
Enthusiast

Joined: Thu May 30, 2013 4:39 pm
Posts: 474
I get very often glitches while I'm scrolling.

Image

Its happened on PB 5.46 and 5.62 OSX 10.7.6 and 10.13.6

I also have the problem that the code folding grphic isn't drawn correct while I'm scrolling.


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Sat Aug 17, 2019 4:20 pm 
Offline
Addict
Addict
User avatar

Joined: Fri Feb 13, 2004 12:45 am
Posts: 2787
Location: Bergen, Norway
Why are you running PB 5.46?
No point in reporting errors for such an old version of PB.

_________________
I Stepped On A Cornflake!!! Now I'm A Cereal Killer!


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Sat Aug 17, 2019 6:56 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 2149
Location: Germany
GeoTrail wrote:
Why are you running PB 5.46?
No point in reporting errors for such an old version of PB.


Last version with ASCII support

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Sat Aug 17, 2019 7:49 pm 
Offline
Addict
Addict
User avatar

Joined: Fri Feb 13, 2004 12:45 am
Posts: 2787
Location: Bergen, Norway
Ok but I don’t see why anyone would use ASCII only today. Overhead shouldn’t be a concern even on 10 year old computers.

_________________
I Stepped On A Cornflake!!! Now I'm A Cereal Killer!


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Sat Aug 17, 2019 10:04 pm 
Offline
Enthusiast
Enthusiast

Joined: Mon Nov 25, 2013 6:41 am
Posts: 799
Quote:
I get very often glitches while I'm scrolling.

Quote:
I also have the problem that the code folding grphic isn't drawn correct while I'm scrolling.

I confirm. pb570 lts mac mojave 10.14.6


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Mon Sep 23, 2019 11:10 pm 
Offline
Addict
Addict

Joined: Mon Aug 04, 2008 10:56 pm
Posts: 1109
Location: Seattle, USA
I'm seeing it too (broken lines) on 5.70LTS running Mojave 10.14.6. I've only gotten the blank (black) screen upon running twice.

_________________
MacBook Pro-r, OSX 10.14.6 , PB 5.70LTS


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Mon Sep 23, 2019 11:29 pm 
Offline
User
User
User avatar

Joined: Fri Feb 02, 2018 10:33 pm
Posts: 14
Location: New Jersey
Oh, thank god!

I thought it was me, or my video driver.

Hope this gets fixed.

_________________
Mac OSX Sierra 10.13.6 & Windows 10, PB 5.71


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Fri Oct 04, 2019 9:00 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Jun 11, 2004 7:07 am
Posts: 610
Same problem here!
OS 10.13.6


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Sat Oct 05, 2019 4:51 pm 
Offline
Addict
Addict

Joined: Mon Aug 04, 2008 10:56 pm
Posts: 1109
Location: Seattle, USA
I've been spending a lot of time with PB 5.70LTS and I've experienced some of the same problems. I have a black box appear (randomly) when scrolling up and down (about 1"x2") and the lines are broken when scrolling sideways. Maybe something changed with Mojave...

_________________
MacBook Pro-r, OSX 10.14.6 , PB 5.70LTS


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Sat Oct 05, 2019 7:44 pm 
Offline
Enthusiast
Enthusiast

Joined: Thu May 30, 2013 4:39 pm
Posts: 474
It has nothing todo with Mojave. I have these problem also on 10.7.
Currently I'm on 10.13 an it's also happened.


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Fri Oct 11, 2019 9:12 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 2149
Location: Germany
Has become better with macOS Catalina

Mac Mini Late 2012 (I7, 16GB)

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Mon Dec 30, 2019 12:59 am 
Offline
Addict
Addict

Joined: Mon Aug 04, 2008 10:56 pm
Posts: 1109
Location: Seattle, USA
..been programming again and have a problem when running a project.

When I run PB with a project the a window comes up but it is all grey. If I click on one of the other tabs that window shows with all the text then if I click back to the original tab I can see the text then. Even if I click on the 'Project' tab (in PB) the file comes up but the screen is grey and I have to click to another tab then back to see the text.

I have the same behavior in 5.71LTS

_________________
MacBook Pro-r, OSX 10.14.6 , PB 5.70LTS


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Mon Dec 30, 2019 2:45 am 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 2149
Location: Germany
I can confirm that.

For some time now, some of my text is sporadically completely white and only after a click in the text window is it displayed correctly.

Except the text cursor is hanging very much after the actual position when changing lines. Especially often with comment lines.

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Mon Dec 30, 2019 11:57 am 
Offline
Enthusiast
Enthusiast

Joined: Mon Sep 10, 2012 10:41 am
Posts: 128
Location: Savoie
GeoTrail wrote:
Ok but I don’t see why anyone would use ASCII only today. Overhead shouldn’t be a concern even on 10 year old computers.

I am still using this version because of this bug https://www.purebasic.fr/english/viewtopic.php?f=24&t=72104
Even if mk-soft provided a workaround.

_________________
MacBook Pro 13" Retina - 16 Gb - OSX 10.14 - Iphone X - iPad at home
...and unfortunately... Windows at work...


Top
 Profile  
Reply with quote  
 Post subject: Re: PB IDE Graphic problem
PostPosted: Sun Jan 05, 2020 1:16 pm 
Offline
Enthusiast
Enthusiast

Joined: Tue Jun 08, 2004 10:29 am
Posts: 226
Location: Zurich, Switzerland
I have this error too; using the most recent version (PB 5.71 LTS (x64) on macOS Catalina 10.15.2

_________________
As you walk on by, Will you call my name? Or will you walk away?


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye