It is currently Sat Dec 07, 2019 7:07 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: PB 5.71 x64 - IDE Hang on opening
PostPosted: Mon Nov 18, 2019 12:16 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Sun Jul 07, 2013 11:35 am
Posts: 444
Location: Canada
Hello everyone,

Here on Ubuntu 19.10 x64 the IDE take a very long time to completely open. The main window open quickly as it should but the source code TabBar, the Scintilla editor and the tool panel take a lot of time to appear.

Best regards
StarBootics

_________________
The Stone Age did not end due to a shortage of stones !


Top
 Profile  
Reply with quote  
 Post subject: Re: PB 5.71 x64 - IDE Hang on opening
PostPosted: Tue Nov 19, 2019 12:18 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Thu Dec 17, 2009 12:00 pm
Posts: 187
Location: Llangadog, Wales, UK
Not sure if this helps much - sorry!

No problem at all starting PB 5.71 x64 on my normal development machine. But this is not Ubuntu - it's running MX Linux 18.3, which is Debian derived (though not Ubuntu derived). The IDE, all parts, loads pretty quickly and is starting up with 9 project tabs open. No noticeable difference from previous versions. The machine is an elderly laptop with 2Gb RAM - not fast!

For Ubuntu 19.10 - I'm only testing from a live DVD. As expected - everything is quite slow, so not a very representative test! However, once the PB IDE window and splash shows up then the code area with all tabs and the side panel seem to be complete and ready fairly quickly. Of course it's slower than my installed system, but appears quite reasonable.

Maybe interesting - on an even older and slower laptop I have PB 5.71 x86, running under MX 32-bit. But if anything, the IDE starts (same project tabs) a little bit quicker than the 64-bit machine. I'm wondering if the available free memory is having an effect?

_________________
www.deeproot.co.uk


Top
 Profile  
Reply with quote  
 Post subject: Re: PB 5.71 x64 - IDE Hang on opening
PostPosted: Sun Nov 24, 2019 12:45 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Sun Jul 07, 2013 11:35 am
Posts: 444
Location: Canada
Hello everyone,

Just to add something, it 20-25 seconds to the IDE to be ready to use. Beside that nothing special to report.

Best regards
StarBootics

_________________
The Stone Age did not end due to a shortage of stones !


Top
 Profile  
Reply with quote  
 Post subject: Re: PB 5.71 x64 - IDE Hang on opening
PostPosted: Sun Nov 24, 2019 4:46 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Thu Dec 17, 2009 12:00 pm
Posts: 187
Location: Llangadog, Wales, UK
StarBootics wrote:
Just to add something, it 20-25 seconds to the IDE to be ready to use
Hi StarBootics - just for comparison, startup timing for PB 5.71 x64 on my MX Linux system, from clicking the launch icon to able to type in the code area: -

"blank" IDE - 4 to 5 seconds
opening with 9 project tabs (total about 36,000 code lines) - 13 to 15 seconds

Hardware is an old HP Compaq 6910p laptop, circa 2007, Core2 Duo, 2Gb RAM, original SATA Disk (don't laugh - I'm on a budget :mrgreen:). I'm pretty happy with load speed of the project and compile time is also good. I use the default Xfce desktop, which probably helps. Be interesting to know what others think?

_________________
www.deeproot.co.uk


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye