It is currently Wed Nov 21, 2018 3:41 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: [Done] PB 5.70 beta 1 - IDE-Bug (x64), does not run!
PostPosted: Thu May 31, 2018 12:09 am 
Offline
Always Here
Always Here
User avatar

Joined: Thu Jun 24, 2004 2:44 pm
Posts: 5745
Location: Berlin - Germany
There comes only the Splashscreen and than nothing more

Tested with Linux Mint 18.3 Cinnamon and Ubuntu 18.04 Cinnamon.

Greetings - Thomas

_________________
PureBasic 5.70 | SpiderBasic 2.10 | Windows 10 Pro (x64) | Linux Mint 19.0 (x64)
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.
Image


Last edited by ts-soft on Wed Jun 06, 2018 11:03 pm, edited 1 time in total.

Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Thu May 31, 2018 12:26 am 
Offline
Addict
Addict
User avatar

Joined: Tue Mar 02, 2004 1:20 pm
Posts: 984
Location: Amphibios 9
Same here: Linux Mint 18.3 Cinnamon 64bit

(32bit PB works as expected)

Greetings ... Peter

Edit: in the 32bit - Version the Tabs are not clickable / closable

_________________
Can't decide if i need a hug, an XXL coffee, 6 shots of vodka or 2 weeks of sleep.


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Thu May 31, 2018 12:54 am 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Sun Jul 07, 2013 11:35 am
Posts: 344
Location: Canada
Same thing with Ubuntu 18.04 x64 with Gnome-shell.

@Fred : By the way you forget to compile the IDE with this line :
Code:
ImportC "-no-pie" : EndImport ; Fix Compiled program flagged as Shared library


Best regards
StarBootics

_________________
The Stone Age did not end due to a shortage of stones !


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Thu May 31, 2018 9:37 am 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Jul 19, 2013 7:36 am
Posts: 164
Location: Novosibirsk
Ubuntu 18.04(64) start IDE = segmentation fault
XUbuntu 16.04(64) start IDE = segmentation fault
Lubuntu 18.04(32) start IDE = segmentation fault

checkinstall.sh OLD!!!!!!!
What has changed in the dependencies for QT???

_________________
Dawn will come inevitably.
His (http://translate.yandex.ru/) English is not as good as we would like
If the English text is not correct, please correct me in private message


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Thu May 31, 2018 9:50 am 
Offline
Administrator
Administrator

Joined: Fri May 17, 2002 4:39 pm
Posts: 13395
Location: France
I will take a closer look. We updated the build server for Linux to use a more recent GCC, it might be that


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Fri Jun 01, 2018 8:05 am 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Jul 19, 2013 7:36 am
Posts: 164
Location: Novosibirsk
KUbuntu 18.04(32)
kubuntu@kubuntu:~/purebasic$ ./launch.sh

(purebasic:4010): Gtk-WARNING **: 07:01:00.744: Unable to locate theme engine in module_path: "adwaita",

(purebasic:4010): Gtk-WARNING **: 07:01:00.758: Unable to locate theme engine in module_path: "adwaita",
./launch.sh: line 1: 4010 Segmentation fault (core dumped) ./compilers/purebasic

_________________
Dawn will come inevitably.
His (http://translate.yandex.ru/) English is not as good as we would like
If the English text is not correct, please correct me in private message


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Wed Jun 06, 2018 9:29 pm 
Offline
Administrator
Administrator

Joined: Fri May 17, 2002 4:39 pm
Posts: 13395
Location: France
Fixed. A new version has been uploaded, feel free to give it a try !


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Wed Jun 06, 2018 9:36 pm 
Offline
Always Here
Always Here
User avatar

Joined: Thu Jun 24, 2004 2:44 pm
Posts: 5745
Location: Berlin - Germany
Thanks, run without problems Image

_________________
PureBasic 5.70 | SpiderBasic 2.10 | Windows 10 Pro (x64) | Linux Mint 19.0 (x64)
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.
Image


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Wed Jun 06, 2018 10:23 pm 
Offline
User
User
User avatar

Joined: Wed Jan 23, 2008 12:45 pm
Posts: 42
Location: France, Montpellier
Ok it starts well! Thanks to Fred and all the team !!! :wink:
under:
Version 16.04.4 LTS (Xenial Xerus) 64-bit
Noyau Linux 4.4.0-128-generic x86_64
MATE 1.12.1

A+ Ulix


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Wed Jun 06, 2018 11:02 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Sun Jul 07, 2013 11:35 am
Posts: 344
Location: Canada
Fred wrote:
I will take a closer look. We updated the build server for Linux to use a more recent GCC, it might be that


Yeah, a newer version of GCC require -no-pie flag to create executable files otherwise they will be flagged as shared libraries. It's weird that we can launch via RunProgram() or through a *.desktop file but not by double click on the file.

That being said it's working so for now let's play with the new stuff.

Best regards
StarBootics

_________________
The Stone Age did not end due to a shortage of stones !


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Thu Jun 07, 2018 6:16 am 
Offline
Enthusiast
Enthusiast

Joined: Sat Feb 08, 2014 3:26 pm
Posts: 512
Fred wrote:
Fixed. A new version has been uploaded, feel free to give it a try !

Thank you Fred,

:arrow: Work fine on Debian 9.4 64bits with xfce.
(runnning on virtual box 5.2.12 on Windows 10 x64 v1802)

Just a message on start console:
Code:
$ ./purebasic
(purebasic:2446): gtk-xfce-engine-CRITICAL **: draw_box_gap: assertion 'height >= -1' failed

But IDE start and all codes works

checkinstall.sh say:
Everything seems correctly setup for PureBasic !

:?: :wink:


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Thu Jun 07, 2018 3:41 pm 
Offline
Addict
Addict

Joined: Wed Nov 12, 2008 5:01 pm
Posts: 1019
Location: Russia
Fred wrote:
A new version has been uploaded
Does not run in Linux Mint 17.
Quote:
./purebasic: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by ./purebasic)
./purebasic: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./purebasic)
./purebasic: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./purebasic)

_________________
Library XP_Menu_Lib - office menu; HID_Lib - USB Library
Torrent client - pbTorrent (source code); Create driver in PureBasic.


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Tue Jun 12, 2018 6:37 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 1444
Location: Germany
PB 5.70 Beta 1 X64

IDE and pbcompiler not a program. Can't start anyone...

Ubuntu 18.04 (X64)

_________________
My Projects OOP-BaseClass / OOP-BaseClassDispatch / Event-Designer /
PB v3.30 / v5.60 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Wed Jun 13, 2018 3:07 pm 
Offline
Enthusiast
Enthusiast

Joined: Sat Feb 08, 2014 3:26 pm
Posts: 512
Quote:
PB 5.70 Beta 1 X64
IDE and pbcompiler not a program. Can't start anyone...
Ubuntu 18.04 (X64)

I have the same thing if I try to run the IDE from a file manager (Thunar 1.6.11 from xfce (on Debian 9.4)
The file manager displays "Shared Library" for purebasic (IDE))

But :!:

if I run the same program from a terminal (xterm), the IDE works
Code:
$ ./purebasic

and works too launching from MC (midnight commander)

:?: :wink:


Top
 Profile  
Reply with quote  
 Post subject: Re: [PB 5.70 beta 1]IDE-Bug (x64), does not run!
PostPosted: Wed Jun 13, 2018 5:26 pm 
Offline
Addict
Addict

Joined: Wed Nov 12, 2008 5:01 pm
Posts: 1019
Location: Russia
Marc56us wrote:
The file manager displays "Shared Library"
The same, but does not run from terminal. The error list in my previous message.

_________________
Library XP_Menu_Lib - office menu; HID_Lib - USB Library
Torrent client - pbTorrent (source code); Create driver in PureBasic.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye