PureBasic Forum
https://www.purebasic.fr/english/

Xcode requirement
https://www.purebasic.fr/english/viewtopic.php?f=19&t=72689
Page 1 of 1

Author:  ssb [ Sun Apr 21, 2019 2:00 am ]
Post subject:  Xcode requirement

Just a simple question regarding PB on MacOS

PureBasic requires the whole Xcode or the much smaller "command line tools" package is enough?

Author:  TI-994A [ Sun Apr 21, 2019 3:28 am ]
Post subject:  Re: Xcode requirement

ssb wrote:
PureBasic requires the whole Xcode or the much smaller "command line tools" package is enough?

The whole Xcode with the command line tools.

Author:  ssb [ Sun Apr 21, 2019 3:48 am ]
Post subject:  Re: Xcode requirement

Thanks for the info!
I hoped I could avoid the Xcode bloat since command line tools contain macOS SDK and compiler toolchain but nevermind :)

Author:  wilbert [ Sun Apr 21, 2019 5:39 am ]
Post subject:  Re: Xcode requirement

ssb wrote:
Thanks for the info!
I hoped I could avoid the Xcode bloat since command line tools contain macOS SDK and compiler toolchain but nevermind :)

If I remember correctly, at least in the past the command line tools were sufficient. :?
You could try the command line tools first and if it's not enough install XCode.

Author:  ssb [ Sun Apr 21, 2019 10:34 am ]
Post subject:  Re: Xcode requirement

Thanks wilbert, I'll give it a try after getting my new MBP.
I hope it works because I hate the idea of 10gb of bloat

Author:  TI-994A [ Sun Apr 21, 2019 11:40 am ]
Post subject:  Re: Xcode requirement

wilbert wrote:
If I remember correctly, at least in the past the command line tools were sufficient...

You're absolute correct. Just tried it with an old MacBook on El Capitan, and it works.

Author:  ssb [ Sun Apr 21, 2019 11:51 am ]
Post subject:  Re: Xcode requirement

TI-994A wrote:
You're absolute correct. Just tried it with an old MacBook on El Capitan, and it works.

You've just made me happy! :D

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/