It is currently Thu Oct 17, 2019 9:27 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: The required compiler cannot be found: PureBasic 5.61 (MacOS
PostPosted: Tue Aug 13, 2019 6:26 pm 
Offline
New User
New User

Joined: Tue Aug 13, 2019 5:51 pm
Posts: 2
Code I wrote in a and earlier version of PB gets this error message in version 5.70:
"The required compiler cannot be found: PureBasic 5.61 (MacOS X - x64)"

Since I opened the code in version 5.70, something must be telling it to look for the older compiler, but I can't find it.

Simple Fix?


Top
 Profile  
Reply with quote  
 Post subject: Re: The required compiler cannot be found: PureBasic 5.61 (M
PostPosted: Tue Aug 13, 2019 7:19 pm 
Offline
New User
New User

Joined: Tue Aug 13, 2019 5:51 pm
Posts: 2
Work around found:

I copied the source into text editor and saved it in another folder with another name. Then double-clicked on the new file.
Got this error "Line 479: Constant not found: #PB_Editor_CompileCount." on this line (suspected culprit of previous error):

TextGadget(997, Tab3, InnerHeight-150, 175, FieldH, "Compiler Count: "+Str(#PB_Editor_CompileCount), #PB_Text_Right)

I commented out the above line and the program worked as expected.


Top
 Profile  
Reply with quote  
 Post subject: Re: The required compiler cannot be found: PureBasic 5.61 (M
PostPosted: Tue Aug 13, 2019 8:13 pm 
Offline
Addict
Addict
User avatar

Joined: Thu Apr 21, 2005 2:38 pm
Posts: 1651
Location: Germany
MacHacker wrote:
Code I wrote in a and earlier version of PB gets this error message in version 5.70:
"The required compiler cannot be found: PureBasic 5.61 (MacOS X - x64)"

Since I opened the code in version 5.70, something must be telling it to look for the older compiler, but I can't find it.

Simple Fix?

Welcome in this PureBasic forum!

Most probably you have specified "PureBasic 5.61 (MacOS X - x64)" in your compiler options. To check this please click onto "Compiler" in PureBasic's menu and select "Compiler Options...". Then remove the checkmark in front of "Use Compiler: PureBasic 5.61 (MacOS X - x64". That should resolve the error message.

Of course it's also possible to install different PureBasic versions in different folders. After installing PB 5.61 again or after letting PureBasic know about other installed PB versions by clicking onto File > Preferences... and then on the left side clicking onto compiler, you are able to add different PB compilers. After this action you should also be able to compile again using PB 5.61...:wink:


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye