PureBasic Forum
https://www.purebasic.fr/english/

Which Gadgets/Functions require libwebkitgtk-3.0 (linker)?
https://www.purebasic.fr/english/viewtopic.php?f=15&t=75620
Page 1 of 1

Author:  Kukulkan [ Mon Jun 29, 2020 1:35 pm ]
Post subject:  Which Gadgets/Functions require libwebkitgtk-3.0 (linker)?

Hi,

I want to use

Code:
ImportC "/usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so"

but in my bigger project, the linker always seem to import libwebkitgtk-3.0.so.0 as it seem to be required for some other thing. I checked all my code and there is no use of WebGadget() in any include. So I think that some PB function or some other gadget may force the linker to include libwebkitgtk-3.0.

Does anyone know what PB function or Gadget is requiring libwebkitgtk-3.0?

UPDATE:
I just found by trial and error that using any XMLDialog function (DialogWindow(), CreateDialog() etc) forces the Purebasic compiler to link libwebkitgtk-3.0. I do not understand as the WebKit browser API does not really offer any helpful functionality (except for its own usage).

Is there a way to use XMLDialog without Purebasic linking against libwebkitgtk-3.0? This is currently completely messing up everything.

I'm really pissed off now. The libwebkitgtk-3.0, used by PureBasic, is not available on most modern Linux Desktops (eg Ubuntu from 19.04 until 20). This is known since January 2018 and did not change until today (mid 2020). And working around this limitation using libwebkit2gtk-4.0 fails because the PureBasic XMLDialog links libwebkitgtk-3.0 for whatever reason. So I can not change my project to use libwebkit2gtk-4.0 together with XMLDialogs (what I do in all projects). And my programs do not run on any modern Linux Desktop...

Is there some basic HTML+CSS rendering engine available for usage in PB without the overhead of 50 megabytes?

Author:  Kukulkan [ Tue Jun 30, 2020 11:06 am ]
Post subject:  Re: Which Gadgets/Functions require libwebkitgtk-3.0 (linker

I do not really need a solution anymore. There is no way to get rid of libwebkitgtk-3.0 if XMLDialog or WebGadget is used. The only solution is QT subsystem, but I can not switch that big project easily.

So it is impossible to run PB executables with XMLDialog or Webgadget on Ubuntu 19.04 and newer. Also other distros are affected (some Linux Mint I think). It is known that libwebkitgtk-3.0 will go away since January 2018 and got never fixed.

Sadly, I believe we will have to port our software using another programming language soon (I think it will be golang with sciter). We already lost a customer because of this...

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/