It is currently Sun Feb 28, 2021 4:51 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: How to use QT subsystem on Kubuntu 16.04 (Xenail)?
PostPosted: Thu Jun 25, 2020 4:10 pm 
Offline
Addict
Addict
User avatar

Joined: Mon Jun 06, 2005 2:35 pm
Posts: 1259
Location: germany
Hi,

I tried to use QT subsystem with PB 5.71 on my Kubuntu 16.04 machine. This is needed because I'm not able to use the WebGadget on Ubuntu systems from 19.04 or newer. There is no libwebkitgtk-3.0-0 available any more, but PB needs this as hard dependency. So I thought I try it with QT as a workaround, as Fred seem to not care about the problem since more than a year...

Sadly, the checkinstall.sh script does not support QT and if I try with the help of freak (link), I get this (German system):

Code:
$ sudo apt-get install qtbase5-dev qttools5-dev qtmultimedia5-dev qtdeclarative5-dev libqt5svg5-dev libqt5webkit5-dev libqt5multimedia5-plugins

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
qtbase5-dev ist schon die neueste Version (5.11.1+dfsg-2+16.04+xenial+build57).
libqt5svg5-dev ist schon die neueste Version (5.11.1-0neon+16.04+xenial+build24).
libqt5multimedia5-plugins ist schon die neueste Version (5.11.1-1+16.04+xenial+build26).
libqt5multimedia5-plugins wurde als manuell installiert festgelegt.
Starting pkgProblemResolver with broken count: 4
Starting 2 pkgProblemResolver with broken count: 4
Investigating (0) qtdeclarative5-dev [ amd64 ] < none -> 5.5.1-2ubuntu6 > ( libdevel )
Broken qtdeclarative5-dev:amd64 Hängt ab von on libqt5qml5 [ amd64 ] < 5.11.1-2+16.04+xenial+build44 > ( libs ) (= 5.5.1-2ubuntu6)
  Considering libqt5qml5:amd64 501 as a solution to qtdeclarative5-dev:amd64 10000
Broken qtdeclarative5-dev:amd64 Hängt ab von on libqt5quick5 [ amd64 ] < 5.11.1-2+16.04+xenial+build44 > ( libs ) (= 5.5.1-2ubuntu6)
  Considering libqt5quick5:amd64 244 as a solution to qtdeclarative5-dev:amd64 10000
Broken qtdeclarative5-dev:amd64 Hängt ab von on libqt5quick5-gles [ amd64 ] < none -> 5.5.1-2ubuntu6 > ( universe/libs )
  Considering libqt5quick5-gles:amd64 1 as a solution to qtdeclarative5-dev:amd64 10000
    Reinst Failed early because of qtbase-abi-5-5-1:amd64
Broken qtdeclarative5-dev:amd64 Hängt ab von on libqt5quickparticles5 [ amd64 ] < none -> 5.5.1-2ubuntu6 > ( libs ) (= 5.5.1-2ubuntu6)
  Considering libqt5quickparticles5:amd64 0 as a solution to qtdeclarative5-dev:amd64 10000
    Reinst Failed early because of qtbase-abi-5-5-1:amd64
Broken qtdeclarative5-dev:amd64 Hängt ab von on libqt5quickparticles5-gles [ amd64 ] < none -> 5.5.1-2ubuntu6 > ( universe/libs )
  Considering libqt5quickparticles5-gles:amd64 1 as a solution to qtdeclarative5-dev:amd64 10000
    Reinst Failed early because of qtbase-abi-5-5-1:amd64
Broken qtdeclarative5-dev:amd64 Hängt ab von on libqt5quicktest5 [ amd64 ] < 5.11.1-2+16.04+xenial+build44 > ( libs ) (= 5.5.1-2ubuntu6)
  Considering libqt5quicktest5:amd64 -1 as a solution to qtdeclarative5-dev:amd64 10000
Broken qtdeclarative5-dev:amd64 Hängt ab von on libqt5quickwidgets5 [ amd64 ] < 5.11.1-2+16.04+xenial+build44 > ( libs ) (= 5.5.1-2ubuntu6)
  Considering libqt5quickwidgets5:amd64 22 as a solution to qtdeclarative5-dev:amd64 10000
Broken qtdeclarative5-dev:amd64 Hängt ab von on libqt5quickwidgets5-gles [ amd64 ] < none -> 5.5.1-2ubuntu6 > ( universe/libs )
  Considering libqt5quickwidgets5-gles:amd64 1 as a solution to qtdeclarative5-dev:amd64 10000
    Reinst Failed early because of qtbase-abi-5-5-1:amd64
Investigating (0) qttools5-dev [ amd64 ] < none -> 5.5.1-3ubuntu0.1 > ( universe/libdevel )
Broken qttools5-dev:amd64 Hängt ab von on libqt5clucene5 [ amd64 ] < none -> 5.5.1-3ubuntu0.1 > ( universe/libs ) (= 5.5.1-3ubuntu0.1)
  Considering libqt5clucene5:amd64 0 as a solution to qttools5-dev:amd64 9999
  Re-Instated libqt5clucene5:amd64
Broken qttools5-dev:amd64 Hängt ab von on libqt5designer5 [ amd64 ] < 5.11.1-2+16.04+xenial+build36 > ( libs ) (= 5.5.1-3ubuntu0.1)
  Considering libqt5designer5:amd64 2 as a solution to qttools5-dev:amd64 9999
Broken qttools5-dev:amd64 Hängt ab von on libqt5designercomponents5 [ amd64 ] < 5.11.1-2+16.04+xenial+build36 > ( libs ) (= 5.5.1-3ubuntu0.1)
  Considering libqt5designercomponents5:amd64 0 as a solution to qttools5-dev:amd64 9999
Broken qttools5-dev:amd64 Hängt ab von on libqt5help5 [ amd64 ] < 5.11.1-2+16.04+xenial+build36 > ( libs ) (= 5.5.1-3ubuntu0.1)
  Considering libqt5help5:amd64 2 as a solution to qttools5-dev:amd64 9999
Investigating (0) libqt5webkit5-dev [ amd64 ] < none -> 5.5.1+dfsg-2ubuntu1 > ( libdevel )
Broken libqt5webkit5-dev:amd64 Hängt ab von on libqt5webkit5 [ amd64 ] < 5.212.0~alpha2-12+16.04+xenial+build37 > ( libs ) (= 5.5.1+dfsg-2ubuntu1)
  Considering libqt5webkit5:amd64 10 as a solution to libqt5webkit5-dev:amd64 9999
Investigating (0) qtmultimedia5-dev [ amd64 ] < none -> 5.5.1-4ubuntu2 > ( libdevel )
Broken qtmultimedia5-dev:amd64 Hängt ab von on libqgsttools-p1 [ amd64 ] < none -> 5.5.1-4ubuntu2 > ( libs ) (= 5.5.1-4ubuntu2)
  Considering libqgsttools-p1:amd64 0 as a solution to qtmultimedia5-dev:amd64 9999
  Re-Instated libqgsttools-p1:amd64
Broken qtmultimedia5-dev:amd64 Hängt ab von on libqt5multimedia5 [ amd64 ] < 5.11.1-1+16.04+xenial+build26 > ( libs ) (= 5.5.1-4ubuntu2)
  Considering libqt5multimedia5:amd64 6 as a solution to qtmultimedia5-dev:amd64 9999
Broken qtmultimedia5-dev:amd64 Hängt ab von on libqt5multimediaquick-p5 [ amd64 ] < none -> 5.5.1-4ubuntu2 > ( libs ) (= 5.5.1-4ubuntu2)
  Considering libqt5multimediaquick-p5:amd64 0 as a solution to qtmultimedia5-dev:amd64 9999
  Re-Instated libqt5multimediaquick-p5:amd64
Broken qtmultimedia5-dev:amd64 Hängt ab von on libqt5multimediawidgets5 [ amd64 ] < 5.11.1-1+16.04+xenial+build26 > ( libs ) (= 5.5.1-4ubuntu2)
  Considering libqt5multimediawidgets5:amd64 -1 as a solution to qtmultimedia5-dev:amd64 9999
Done
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libqt5webkit5-dev : Hängt ab von: libqt5webkit5 (= 5.5.1+dfsg-2ubuntu1) aber 5.212.0~alpha2-12+16.04+xenial+build37 soll installiert werden
 qtdeclarative5-dev : Hängt ab von: libqt5qml5 (= 5.5.1-2ubuntu6) aber 5.11.1-2+16.04+xenial+build44 soll installiert werden
                      Hängt ab von: libqt5quick5 (= 5.5.1-2ubuntu6) aber 5.11.1-2+16.04+xenial+build44 soll installiert werden oder
                                     libqt5quick5-gles soll aber nicht installiert werden
                      Hängt ab von: libqt5quickparticles5 (= 5.5.1-2ubuntu6) soll aber nicht installiert werden oder
                                     libqt5quickparticles5-gles soll aber nicht installiert werden
                      Hängt ab von: libqt5quicktest5 (= 5.5.1-2ubuntu6) aber 5.11.1-2+16.04+xenial+build44 soll installiert werden
                      Hängt ab von: libqt5quickwidgets5 (= 5.5.1-2ubuntu6) aber 5.11.1-2+16.04+xenial+build44 soll installiert werden oder
                                     libqt5quickwidgets5-gles soll aber nicht installiert werden
 qtmultimedia5-dev : Hängt ab von: libqt5multimedia5 (= 5.5.1-4ubuntu2) aber 5.11.1-1+16.04+xenial+build26 soll installiert werden
                     Hängt ab von: libqt5multimediawidgets5 (= 5.5.1-4ubuntu2) aber 5.11.1-1+16.04+xenial+build26 soll installiert werden
 qttools5-dev : Hängt ab von: libqt5designer5 (= 5.5.1-3ubuntu0.1) aber 5.11.1-2+16.04+xenial+build36 soll installiert werden
                Hängt ab von: libqt5designercomponents5 (= 5.5.1-3ubuntu0.1) aber 5.11.1-2+16.04+xenial+build36 soll installiert werden
                Hängt ab von: libqt5help5 (= 5.5.1-3ubuntu0.1) aber 5.11.1-2+16.04+xenial+build36 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


Any idea how I can use the QT subsystem? There seem to be a lot of dependency issues and version incompatibilities...


Top
 Profile  
Reply with quote  
 Post subject: Re: How to use QT subsystem on Kubuntu 16.04 (Xenail)?
PostPosted: Thu Jun 25, 2020 5:40 pm 
Online
Enthusiast
Enthusiast

Joined: Mon Apr 10, 2017 6:17 pm
Posts: 414
Location: Germany
Kukulkan wrote:
Any idea how I can use the QT subsystem? There seem to be a lot of dependency issues and version incompatibilities...


Did you give the linux install a try? It supports GTK and QT.

_________________
webpage


Top
 Profile  
Reply with quote  
 Post subject: Re: How to use QT subsystem on Kubuntu 16.04 (Xenail)?
PostPosted: Thu Jun 25, 2020 7:42 pm 
Offline
Addict
Addict
User avatar

Joined: Mon Jun 06, 2005 2:35 pm
Posts: 1259
Location: germany
Hi,

the page is having SSL Certificate issues. Not that trustworthy. And behind, there is a tool to make executable setups. But I like to compile using PB with QT, and this does not work because of missing dependencies. And trying to install them results in the errors from first post. How is this to get fixed by that installer-tool? Maybe I did not understand?


Top
 Profile  
Reply with quote  
 Post subject: Re: How to use QT subsystem on Kubuntu 16.04 (Xenail)?
PostPosted: Thu Jun 25, 2020 9:10 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 2878
Location: Germany
Ubuntu 16.04 is out of LTS. Is better to update Ubuntu 18.04 LTS.
No problem with QT

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: How to use QT subsystem on Kubuntu 16.04 (Xenail)?
PostPosted: Fri Jun 26, 2020 8:28 am 
Offline
Addict
Addict
User avatar

Joined: Thu Apr 21, 2005 2:38 pm
Posts: 1812
Location: Germany
mk-soft wrote:
Ubuntu 16.04 is out of LTS.

That's not correct. The general support of Ubuntu 16.04 LTS ends in 2021-04, the security support in 2024-04. You may take a look into this release table in Wikipedia.


Top
 Profile  
Reply with quote  
 Post subject: Re: How to use QT subsystem on Kubuntu 16.04 (Xenail)?
PostPosted: Fri Jun 26, 2020 11:48 am 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Jul 19, 2013 7:36 am
Posts: 254
Location: Novosibirsk
I have been asking for a long time for an up-to-date checkinstall and an official statement about which Linux distributions (including their versions) are supported.
But I have never received an answer.

I understand that Fred and the company's resources are limited.
That is why I am waiting for an honest specific list.

_________________
Dawn will come inevitably. ( Рассвет наступит неизбежно )


Top
 Profile  
Reply with quote  
 Post subject: Re: How to use QT subsystem on Kubuntu 16.04 (Xenail)?
PostPosted: Fri Jun 26, 2020 5:00 pm 
Online
Enthusiast
Enthusiast

Joined: Mon Apr 10, 2017 6:17 pm
Posts: 414
Location: Germany
Kukulkan wrote:
the page is having SSL Certificate issues. Not that trustworthy.


My hoster made same mistake during the last upgrade. Dunno when that will be fixed.

Kukulkan wrote:
How is this to get fixed by that installer-tool? Maybe I did not understand?


The tool knows the necessary GTK and QT Libraries and recognizes the environment it runs on. It shows the detected environment (so the user can verify it and abort it if something seems wrong).

Then it looks for matching setup files of the selected UI's you want to use and if it knows the required libraries for the current environment it runs in. Then you can simply let the tool install all required libraries with a click. The tool supports 32-bit and 64-bit linux installations and if things go as expected, any Linux preparation for different UI developments is a 2 or 3 mouseclick effort. But i can relate that you would not download and run a "unknown" binary from an "unsafe" website due to the SSL problem currently.

The full source is in the archive though and the environment detection and matching basically points to a ascii textfile which includes the list of required libraries. So you could download it but instead of installing and running, decompress it and manually use the text files from the architecture folder to do the same ;)

Btw. the next big trust problem would have been the fact that the installation of libraries would really require root rights to start the package manager ;)

To deal with all these trust problems, i simply develop inside linux virtual machines.

useful wrote:
I have been asking for a long time for an up-to-date checkinstall and an official statement about which Linux distributions (including their versions) are supported.
But I have never received an answer.

I understand that Fred and the company's resources are limited.
That is why I am waiting for an honest specific list.


Thats exactly the reason why i started the linux installer project and the necessary tool. Fred gave us the tools we need to do this ourselves.

_________________
webpage


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye