It is currently Wed Jan 27, 2021 8:57 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sun Mar 15, 2020 5:26 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 2820
Location: Germany
Unpack Purebasic
- Create on "Private Folder" an Apps folder
- Unpack Purebasic into this folder
- Rename folder with versions number. Example "purebasic" -> "purebasic-v572"

Desktop Link File for Purebasic
- Create desktop file with GEdit
- Change path to purebasic and save as "purebasic-v5.72.desktop" on desktop folder.
- Change property of desktop file to enable "Run As Program"
- Since Ubuntu 20.04: On desktop "Enable start" over context menu

Quote:
[Desktop Entry]
Type=Application
Icon=/home/michael/Apps/purebasic-v572/logo.png
Name=Purebasic v5.72
Comment=Developer Utility
Exec=/home/michael/Apps/purebasic-v572/compilers/purebasic
Path=/home/michael/Apps/purebasic-v572/compilers
StartupNotify=false
Terminal=false



Install Developer Packets
- Info: Required Webkit not available on Ubuntu v19.x. We wait for update of Purebasic
- Start Terminal and install packets
Quote:
Purebasic
---------
sudo apt-get install build-essential gcc g++

sudo apt-get install libxxf86vm-dev libxine2-dev unixodbc-dev libsdl1.2-dev libsdl2-dev

sudo apt-get install libgtk2.0-dev libgtk-3-dev

sudo apt-get install libwebkitgtk-dev libwebkitgtk-3.0-dev libwebkit2gtk-4.0-dev


Subsystem qt
------------
sudo apt-get install qtbase5-dev qttools5-dev qtmultimedia5-dev qtdeclarative5-dev libqt5svg5-dev libqt5webkit5-dev libqt5multimedia5-plugins


Ubuntu Gnome 18.xx (For PB-IDE)
-------------------------------
sudo apt install libcanberra-gtk-module


Obsoleted
---------
;sudo apt-get install libgnome2-dev
;sudo apt-get install libgnomeprintui2.2-dev libxine-dev


Ubuntu missing default libs (Without developer packets)
-------------------------------------------------------
gtk2
- sudo apt-get install libgtk2.0
gtk3
- sudo apt-get install libwebkitgtk-3.0
qt
- sudo apt install qt5-default

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Last edited by mk-soft on Sat Oct 17, 2020 1:15 pm, edited 3 times in total.

Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sun Mar 29, 2020 10:42 am 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 2820
Location: Germany
I once updated my simplified installation without using scripts and path extensions of Purebasic.
:wink:

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Fri Apr 17, 2020 1:39 am 
Offline
Enthusiast
Enthusiast

Joined: Mon Jul 09, 2007 4:47 pm
Posts: 228
Location: Courthouse
Interesting and informative.
Many thanks.


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sat Apr 18, 2020 10:03 am 
Offline
User
User

Joined: Sun May 14, 2017 1:48 am
Posts: 59
code highlighting for Geany - download


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Thu Apr 30, 2020 10:25 pm 
Offline
New User
New User

Joined: Mon Sep 02, 2019 7:46 pm
Posts: 6
Thank you very much for this guide, it helps me a lot!


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sat Jun 06, 2020 10:03 am 
Offline
User
User
User avatar

Joined: Fri Jun 07, 2019 1:56 pm
Posts: 77
Hello,

I'm totally new with linux!

Did everything what is described in this posting.

When I want to start the program by click onto the icon I get this error:

Failed to execute child process "Path" (Permission denied")

What to do to start the Purebasic?

Thanks for your help in advance

Rainer


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sat Jun 06, 2020 11:25 am 
Offline
Enthusiast
Enthusiast

Joined: Mon Apr 10, 2017 6:17 pm
Posts: 403
Location: Germany
The official way is to run checkinstall.sh and then if everything is ok, run launch.sh. You unzip, untar the purebasic archive and then "cd purebasic" into the extracted folder.

I start the (custom bugfixed version from mk-soft i got from the purebasic discord chat - join it!) IDE manually by first elevating my terminal user rights (sudo /bin/bash) and then run the IDE directly purebasic/compilers/purebasic
That works and avoids trouble with user rights the IDE otherwise might have, but linuxers will likely tell you never to do that because of the potential security risk (any breach of the purebasic IDE will get the attacker a root shell to your machine).

_________________
webpage


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sat Jun 06, 2020 1:07 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 2820
Location: Germany
There should be no legitimate problems in personal folders (not documents folders) to run apps.
Don't know what it looks like under all Linux distributions.

Maybe unpacked in the wrong folder
or not set the option "Run as Program" in the properties of Icon.

The bugfixed Linux IDE can be found here:
- AutoComplete Bugfix

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sat Jun 06, 2020 2:41 pm 
Offline
User
User
User avatar

Joined: Fri Jun 07, 2019 1:56 pm
Posts: 77
Hi, tested this too.

No success.

I think I will give up with linux, all things with this OS are so horrible complicated.

Thanks a lot
Rainer


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sat Jun 06, 2020 3:13 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 2820
Location: Germany
Give up so easily?

1. Correct version taken. PB X64 for Linux X64
2. Double-click on Archives and then drag and drop the folder into your Personal Folder. (Create folder 'Apps')
3. Installed the required libs in the terminal

4. Open PB folder (./Apps/purebasic/compilers) and double click on program 'purebasic'

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sat Jun 06, 2020 3:26 pm 
Offline
User
User
User avatar

Joined: Fri Jun 07, 2019 1:56 pm
Posts: 77
mk-soft wrote:
Give up so easily?

1. Correct version taken. PB X64 for Linux X64
2. Double-click on Archives and then drag and drop the folder into your Personal Folder. (Create folder 'Apps')
3. Installed the required libs in the terminal

4. Open PB folder (./Apps/purebasic/compilers) and double click on program 'purebasic'


Hi, thanks, I did all this without any success.

I'm programming all apps for Windows. I simply wanted to test if my sources are also running under Linux, and how they are looking.

Rainer


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sat Jun 06, 2020 3:29 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 2820
Location: Germany
Which linux version do you use?
Which vm ware do you use? (VirtualBox, e.g.)

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sat Jun 06, 2020 3:31 pm 
Offline
User
User
User avatar

Joined: Fri Jun 07, 2019 1:56 pm
Posts: 77
mk-soft wrote:
Which linux version do you use?


Hi it's installed on an old IBM-Laptop. The version is Linux Mint Mate 13 32bit. An I used the 86 version from PureBasic.

Rainer


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sat Jun 06, 2020 4:03 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 2820
Location: Germany
Ah,
Ok, use older version from purebasic (pb v5.70)
Its a problem with zlib.
You can see the problem, when you starting the ide from terminal.
Quote:
michael@Ubuntu-1604:~/Apps/purebasic-v572/compilers$ ./purebasic
./purebasic: /lib/i386-linux-gnu/libz.so.1: version `ZLIB_1.2.9' not found (required by ./purebasic)


My fixed IDE can work with pb v5.70

P.S. Alternate
Install VirtuelBox and VirtualBox Extension Pack on windows
Create Linux Machines: Examples
- Ubuntu 18.04 LTS (If used WebGadget)
- Ubuntu 20.04 LTS

Link: https://www.virtualbox.org/wiki/Downloads

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: Simple install of PureBasic (Ubuntu, Mint)
PostPosted: Sat Jun 06, 2020 4:23 pm 
Offline
User
User
User avatar

Joined: Fri Jun 07, 2019 1:56 pm
Posts: 77
Thank you very much for your help.

I have invested a long time to install Linux on this old machine. Even this was difficult and a lot of commands in the terminal have been necessary. Started my programming with MSDOS and then from Windows 1 to 10. So I'm an experienced user of Windows. Click INSTALL and ready! It was a horrible experience even to install Linux, tested a lot of versions, not one was installing without my deep editing help.

At least this version was running. But not PB.

It's not so important for me, just curious.

Thanks, Rainer.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye