PureBasic Forum
https://www.purebasic.fr/english/

Ubuntu 19 libxine and checkinstall problems
https://www.purebasic.fr/english/viewtopic.php?f=15&t=73714
Page 1 of 1

Author:  Bitblazer [ Tue Oct 01, 2019 1:22 pm ]
Post subject:  Ubuntu 19 libxine and checkinstall problems

Image

result from apt cache search

Image

I installed libxine2 but that did not help. The xine project download does not even list a downloadable ubuntu package and it is a bit unrealistic that anybody manually compiles the libxine sources to overcome the failing checkinstall especially if they dont even intend to use any sound / multimedia functions.

I consider that a basic problem of the current checkinstall script. It assumes you want to use every single language element and that is a problem if bindings arent up to date. Great if it works, but that (imho) requires regular maintenance.

So what is the solution? An enhanced checkinstall mechanism which asks for the components people intend to use any only checks those? But it would probably be simpler to update the library compilations to work with libxine2 and more recent library versions alternatively (webkit is another regularly troublesome dependancy).

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/