It is currently Fri Jun 22, 2018 6:43 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Works debug in Ubuntu 17.04?
PostPosted: Mon Oct 02, 2017 9:19 am 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Apr 25, 2003 7:09 pm
Posts: 234
Location: (Madrid) Spain
I have linux Purebasic version 5.61 (x64), on Ubuntu 17.04.
Debug works perfectly until some days. Breakpoints works, but I cannot run step by step.

I think it is for some update, but I am not sure. Anyone with same problem, or it is only me?

_________________
[:: PB Registered ::]

Win8.1 Intel Quad 2.4GHz 4GB RAM Nvidia GTX 750Ti


Top
 Profile  
Reply with quote  
 Post subject: Re: Works debug in Ubuntu 17.04?
PostPosted: Wed Oct 04, 2017 10:42 am 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Apr 25, 2003 7:09 pm
Posts: 234
Location: (Madrid) Spain
Anyone with this problem in Linux?

Thanks.

_________________
[:: PB Registered ::]

Win8.1 Intel Quad 2.4GHz 4GB RAM Nvidia GTX 750Ti


Top
 Profile  
Reply with quote  
 Post subject: Re: Works debug in Ubuntu 17.04?
PostPosted: Wed Oct 04, 2017 11:46 am 
Offline
User
User
User avatar

Joined: Wed Mar 15, 2006 1:47 pm
Posts: 49
Location: Munich
I am using Kubuntu 17.04 and it works flawlessly here.

Maybe try it with a live disk and see if you can reproduce the problem on a clean setup,
if not, you know its something you have installed/running in the background.

Have you also tried to use Step by Step with the IDEs buttons?
Maybe its just something catching your F8 keypresses.


Top
 Profile  
Reply with quote  
 Post subject: Re: Works debug in Ubuntu 17.04?
PostPosted: Wed Oct 04, 2017 2:09 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Apr 25, 2003 7:09 pm
Posts: 234
Location: (Madrid) Spain
The IDE buttons get disabled, and F8 simply don't work.
If you pc works ok, I suppose there must be anything wrong in my machine. I'll try to investigate or reinstall pb.

Thank you.

_________________
[:: PB Registered ::]

Win8.1 Intel Quad 2.4GHz 4GB RAM Nvidia GTX 750Ti


Top
 Profile  
Reply with quote  
 Post subject: Re: Works debug in Ubuntu 17.04?
PostPosted: Wed Oct 04, 2017 5:27 pm 
Offline
User
User
User avatar

Joined: Wed Mar 15, 2006 1:47 pm
Posts: 49
Location: Munich
So I had time to do some testing and noticed that the buttons are greyed out for me in the following cases:

I stop the program during a delay call (The buttons are enabled as soon as the delay has passed)

The program is in a call to an external library. Here the buttons to become responsive after the call has finished.
This also seems to be the case if any thread accesses a external library. (Just quick testing)
So maybe your code gets stuck in an external call?


Top
 Profile  
Reply with quote  
 Post subject: Re: Works debug in Ubuntu 17.04?
PostPosted: Thu Oct 05, 2017 9:04 am 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Apr 25, 2003 7:09 pm
Posts: 234
Location: (Madrid) Spain
I discovered the problem.
When I execute OpenScreen(1920,1080,32,"") or another resolution, the debug commands and buttons deactivate. Yes, F8 also don't work. Can you check it please?

I don't know what is exactly the problem, because I was debuging the program flawlessly.

Could any system update modify purebasic debug?

_________________
[:: PB Registered ::]

Win8.1 Intel Quad 2.4GHz 4GB RAM Nvidia GTX 750Ti


Top
 Profile  
Reply with quote  
 Post subject: Re: Works debug in Ubuntu 17.04?
PostPosted: Thu Oct 05, 2017 9:32 am 
Offline
User
User
User avatar

Joined: Wed Mar 15, 2006 1:47 pm
Posts: 49
Location: Munich
You are right, I can confirm it.
Also with Purebasic 4.44.

Here under Kubuntu I also cannot tab out of a screen.
Seems like you have a bug to report.

If I have time later today, I will try if the problem also exists with older Linux Versions in a VM
(because I haven't used the Screen library for ages)


Top
 Profile  
Reply with quote  
 Post subject: Re: Works debug in Ubuntu 17.04?
PostPosted: Thu Oct 05, 2017 1:39 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Fri Apr 25, 2003 7:09 pm
Posts: 234
Location: (Madrid) Spain
I don't understand anything. I tested it in Windows and Mac, and have the same problem.
It must be a common problem, but I have a very long program and worked ok, because I had to debug a lot of functions. :shock:

So, is not possible debug a program when using OpenScreen() ?

_________________
[:: PB Registered ::]

Win8.1 Intel Quad 2.4GHz 4GB RAM Nvidia GTX 750Ti


Top
 Profile  
Reply with quote  
 Post subject: Re: Works debug in Ubuntu 17.04?
PostPosted: Sat Oct 21, 2017 2:26 pm 
Offline
Enthusiast
Enthusiast

Joined: Thu May 21, 2009 6:56 pm
Posts: 446
Hi

I also experience this problem in PB 5.45 on Linux OpenSuse 43.2. Once the buttons are greyed out they never start working again, instead I have to restart PB.

Simon


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye