Again, a minor request but a "nice to have" IMHO.
By way of comment I don't think this request makes sense to have.
Notice the other words you used as examples:
We have EndIf, EndSelect, EndEnumeration, EndInterface, EndStructure, EndWith, EndProcedure, EndImport and EndMacro ... the only other termination keyword with "end" in it is Wend ... just seems like EndWhile would be more consistent there.
I Notice that you left out a few other 'end'-ing keywords. They're all looping words: Next, Until, Forever, and Wend. Would you suggest, for consistency, to use in addition to EndWhile to also moving to EndFor, EndRepeat, EndRepeatALot? That would seem a scary prospect. The alternative of just adding EndWhile and leaving the rest with no 'additions' wouldn't be consistent.
The looping words were chosen (for the most part
) because they make sense, not because they followed a pattern. To be consistent they should be left as they are without the need of any syntatic sugar. You already mentioned how you would do it with a macro if you wanted it (though, if it is for a beginner you've already moved into more advanced territory).
Furthermore, what about other keywords such as Return, or the function names in libraries: StopDrawing(), Stop3D(), StopSpecialFX(), StopPrinting()?
Even though I'm not a newbie and this is a minor request, I still wouldn't be in favor of this (-1).