It is currently Tue Apr 25, 2017 1:50 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: OK but not Unicode executable
PostPosted: Fri Mar 03, 2017 8:17 pm 
Offline
User
User

Joined: Wed Jun 23, 2010 5:13 pm
Posts: 87
Hi,
My program (which uses dll registration using string) runs in nonUnicode mode OK. But if I create Unicode executable the app fails registering dll with serial in string. This dll supports unicode mode as running in VisualStudio unicode mode accepts serial.
The problem is with only registering with serial in unicode executable.

Will be very thankful for any hint.


Top
 Profile  
Reply with quote  
 Post subject: Re: OK but not Unicode executable
PostPosted: Fri Mar 03, 2017 9:20 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Tue Oct 09, 2007 2:15 am
Posts: 762
some code is needed...

but I think you have to convert the strings to ascii before you send them to the dll functions.

_________________
PureBasic 5.44 LTS / 5.60 (Windows x86/x64) | Windows10 Pro x64 | Z87-PLUS | i7 4770k | 32GB RAM | iChill GeForce GTX 980 X4 Ultra | HAF XF Evo​​
English is not my native language...


Top
 Profile  
Reply with quote  
 Post subject: Re: OK but not Unicode executable
PostPosted: Sat Mar 04, 2017 7:48 am 
Offline
User
User

Joined: Wed Jun 23, 2010 5:13 pm
Posts: 87
ThanQ very much,
Unicode2Ansi solved the problem


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye