It is currently Sat Apr 21, 2018 11:57 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 26 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Ubuntu 16 - dependancies?
PostPosted: Sun May 22, 2016 2:36 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jul 08, 2013 8:43 pm
Posts: 224
Hello, im trying to install PB over Ubuntu16 (or mate) OS and i have many error type GDK and others.
Im working with Ubuntu 6 to 11 an PB with no problems..
Some body know what dependancies need install before run PB?
An for movies I use Xine following instructions but not..
some body have .sh file to do this more easy?
Greetings and thanks

_________________
If translation=Error: reply="Sorry, Im Spanish": Endif


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Mon May 23, 2016 9:22 am 
Offline
Addict
Addict
User avatar

Joined: Fri Apr 12, 2013 1:55 pm
Posts: 1057
Location: just outside of Ferguson
I used the script contained in a comment within the 7th line of the checkinstall.sh file in the main install folder, and it worked to permit PureBasic to run in UBUNTU 16.04 x64
Code:
apt-get install gcc g++ libc6-dev libsdl1.2-dev libgtk-3-dev unixodbc-dev libgnome2-dev libxine2-dev libxxf86vm-dev

For video I installed VLC and the system has have everything needed to produce superb video playback.

_________________
Keep it BASIC.


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Tue May 24, 2016 3:56 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jul 08, 2013 8:43 pm
Posts: 224
heartbone wrote:
I used the script contained in a comment within the 7th line of the checkinstall.sh file in the main install folder, and it worked to permit PureBasic to run in UBUNTU 16.04 x64
Code:
apt-get install gcc g++ libc6-dev libsdl1.2-dev libgtk-3-dev unixodbc-dev libgnome2-dev libxine2-dev libxxf86vm-dev

For video I installed VLC and the system has have everything needed to produce superb video playback.


Thanks heartbone!
I run to try again. ;-)

_________________
If translation=Error: reply="Sorry, Im Spanish": Endif


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Wed May 25, 2016 3:21 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jul 08, 2013 8:43 pm
Posts: 224
I have a GTK error..
gtk (MESSAGE): gtk dialog mapped without transient parent. This is discouraged.

Im using Ubuntu Mate 16.04 amd64.
May be better use another distro with PB?

Some body know any thing about this.
Thanks?

_________________
If translation=Error: reply="Sorry, Im Spanish": Endif


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Wed May 25, 2016 3:51 pm 
Offline
Addict
Addict
User avatar

Joined: Thu Jun 04, 2015 7:10 am
Posts: 1673
minimy wrote:
May be better use another distro with PB?

ive only been using Linux for about 1yr but ive always used Linux Mint and never had any real problems with it in regards to Purebasic (and im a relative newb). It's Ubuntu-based too! I just like it because its one of the more user-friendly Linuxii which is helpful to me coming from Windows :)

_________________
Thankyou to all the coders who generously helped & encouraged me in the nearly 2yrs when i was welcome here,
it was a tremendous privilege. I learned a lot. I wish you and your families all the best and success for the future.


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Wed May 25, 2016 4:30 pm 
Offline
Enthusiast
Enthusiast

Joined: Thu Jun 26, 2014 9:17 am
Posts: 281
Location: Germany
Hi minimy!

There's a change in newer Ubuntu versions (15.x and up). A parent window is demanded for some dialogs like MessageRequester. It's an incompatibility to older gtk-versions and other OS's. I think we have to wait, whether Fred finds a solution, because up to now 'homeless' dialogues were possible on all OS?

@Keya
Mint 17.3 is based on Ubuntu 14.04, i think. So don't be disappointed - in future Mint updates you'll get this error too :wink: .
Best regards, Charly

_________________
PureBasic 5.3-5.5, Linux: (X/L/K)Ubuntus+Mint - Windows XP (32Bit)
PureBasic Linux-API-Library & Viewer: http://www.chabba.de


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Wed May 25, 2016 7:18 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jul 08, 2013 8:43 pm
Posts: 224
Hello, Oma and Keya, PB forum is simply the best! :D
Oma do you know if installing pak with old gtk may be a solution?
Keya you have installed the last mint distro, 17.3?, and you can play movie commands from PB?
Thanks a lot to both!

_________________
If translation=Error: reply="Sorry, Im Spanish": Endif


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Wed May 25, 2016 7:53 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jul 08, 2013 8:43 pm
Posts: 224
Solved!!! Yeahhh!!! :D :lol:
Installing all packets again, and i put old gtk too.. (in case OS need, i dont know..)

sudo apt-get update
sudo dpkg --configure -a
sudo apt-get -flx-broken install

And now work movie comands!
Aleluyaaaa!! :mrgreen:

_________________
If translation=Error: reply="Sorry, Im Spanish": Endif


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Wed May 25, 2016 8:29 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jul 08, 2013 8:43 pm
Posts: 224
Bad news..
After work two times, gtk error is back.
But not always have error. Is really extange.
Go to install Ubuntu 12 or 13.

_________________
If translation=Error: reply="Sorry, Im Spanish": Endif


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Thu May 26, 2016 6:22 am 
Offline
Enthusiast
Enthusiast

Joined: Thu Jun 26, 2014 9:17 am
Posts: 281
Location: Germany
Hello Minimy,
it's just a 'warning' from gtk, not a programm termination! And it's something which can be seen occasionally on Linux, due to buggy themes and other reasons. But there is no reason to be too nervous for this reason. (And the warning has nothing to do with non working movies!)

I.e. a simple
Code:
MessageRequester("Title", "Message")
works on (X-/L-/K-) Ubuntus up to 14.10 and (i think) Mint 17.3 without the mentioned warning (this are solid working LTS versions which got regulary updates for some time). However the warning appears on (K-) Ubuntu 15.10 (and maybe 15.04 too ?).
The choose of the derivate is a matter of taste.

I never noticed that the Movie Library has such problems under linux (14.x and 15.x-Ubuntus). It seems to be difficult to find the appropriate library files.
Here' a link where shardik tried to find them (i didn't try it).http://www.purebasic.fr/english/viewtopic.php?f=15&t=61290

Best regards and good luck, Charly

_________________
PureBasic 5.3-5.5, Linux: (X/L/K)Ubuntus+Mint - Windows XP (32Bit)
PureBasic Linux-API-Library & Viewer: http://www.chabba.de


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Thu May 26, 2016 1:04 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jul 08, 2013 8:43 pm
Posts: 224
Thanks friends to take time to solve this question.

Oma you are right! I think we need wait Fred solve this. (pease Fred, and maybe fps in float format :oops: )
Im back to Ubu12.04 because i know this distro work fine and lightweight for VM or old computer!
Im trying to do a pbi file multisys (win,mac,linux) to use quickly in any OS. I start with movie lib and see this problem in MATE16.. :evil:
But not problem continues with others.. :mrgreen: This in only one battle.. :lol:
Any way.. PB is the best foreverer!

_________________
If translation=Error: reply="Sorry, Im Spanish": Endif


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Thu May 26, 2016 6:53 pm 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 1195
Location: Germany
I have installed Ubuntu 16.04 LTS Desktop X86 and X64 as VM.
After the update on the ubuntu software I've installed the following packages
Quote:
sudo apt-get install build-essential gcc g++ libc6-dev libgtk2.0-dev libgnome2-dev libgtk-3-dev
sudo apt-get install libxxf86vm-dev libxine2-dev unixodbc-dev libsdl1.2-dev libsdl2-dev
sudo apt-get install libwebkitgtk-dev libwebkitgtk-3.0-dev libwebkit2gtk-4.0-dev

It´s runnring :wink:

_________________
My Projects OOP-BaseClass / OOP-BaseClassDispatch / Event-Designer /
PB v3.30 / v5.60 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Sun May 29, 2016 1:55 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jul 08, 2013 8:43 pm
Posts: 224
mk-soft wrote:
I have installed Ubuntu 16.04 LTS Desktop X86 and X64 as VM.
After the update on the ubuntu software I've installed the following packages
Quote:
sudo apt-get install build-essential gcc g++ libc6-dev libgtk2.0-dev libgnome2-dev libgtk-3-dev
sudo apt-get install libxxf86vm-dev libxine2-dev unixodbc-dev libsdl1.2-dev libsdl2-dev
sudo apt-get install libwebkitgtk-dev libwebkitgtk-3.0-dev libwebkit2gtk-4.0-dev

It´s runnring :wink:


Hi mk-soft, thanks for your help. I have a lot of VR machines, fedora,ubuntu,xubuntu,lubuntu,suse,.. (Im looking for stable and PB friendly distro)
Linux is awesome and like me a lot, speedy, secure, stable and preety desktops.
Any way.. I download again Ubu16.04LTS(32 and 64), install and follow all steps you say. Try one time installing linux, update and install all packs.
Install 32 and 64 bit two times following all steps.. a lot of time, a lot of cofees :lol: .oO(I remember my spectrum and amiga times)
But i have same gdk error in both versions 32/64bit.

Are you using a VBox machine?. You can play movies using PB?
In any distros i got all system working good (no gdk error), except movie comands.

My next step is use an old PC install Linux as primary OS and try again.. :mrgreen: .oO(with more cofee and cookies box)
Thanks again for your time.

_________________
If translation=Error: reply="Sorry, Im Spanish": Endif


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Thu Jun 02, 2016 12:59 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Mon Jul 08, 2013 8:43 pm
Posts: 224
Keya wrote:
minimy wrote:
May be better use another distro with PB?

ive only been using Linux for about 1yr but ive always used Linux Mint and never had any real problems with it in regards to Purebasic (and im a relative newb). It's Ubuntu-based too! I just like it because its one of the more user-friendly Linuxii which is helpful to me coming from Windows :)


Hello again (a lot of coffes and many distros later.. :lol: ), Keya yo use mint, with Mint all work fine, but do you can play movies with PB, because with example movie.pb i only see a black window, no video, no audio. I try mp4, avi (xvid) and others. Mint play all movies very good but PB not.
Some body can help with this?
Thanks!

_________________
If translation=Error: reply="Sorry, Im Spanish": Endif


Top
 Profile  
Reply with quote  
 Post subject: Re: Ubuntu 16 - dependancies?
PostPosted: Thu Jun 02, 2016 2:05 pm 
Offline
Enthusiast
Enthusiast

Joined: Thu Jun 26, 2014 9:17 am
Posts: 281
Location: Germany
Hello again, minimy!

Had my coffee too, and now Mint 17.3 :wink: .
I did the installations (mentioned in the link above) and now it runs (only tested with 1 mpg)
Please try:
Quote:
sudo apt-get install mesa-vdpau-drivers
sudo apt-get install libxine2-dev
sudo apt-get install libxine2-x
sudo apt-get install libxine2
and good luck.
Best Regards, Charly

_________________
PureBasic 5.3-5.5, Linux: (X/L/K)Ubuntus+Mint - Windows XP (32Bit)
PureBasic Linux-API-Library & Viewer: http://www.chabba.de


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 26 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye